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Registration 
 

When running an unregistered version of Diamond Discovery Payroll a warning message will 
be presented.   

 

  
 

From here, either go to the registration screen by clicking Yes, or use the product in 

demonstration mode by selecting No.  In demonstration mode the software will run for an 
unlimited time, but will only perform calculations for the first three pay periods and for a 

maximum of 5 employees. 
 

 
If you have purchased a PIN 

 

To register the product you will have to enter your name and your company name.  These 
are not validated in anyway and are required only for licensing purposes.   

Next enter the PIN supplied with the software and click the Check button.  If an error 
message is received, then please double check the PIN.  

 

 

 
 

Please note: The PIN number shown here is for example only and will not register the 
product. 
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If the PIN has been entered correctly the Register button will become active.  Click this to 

complete the operation. 

 
 
 

Important: The default username & password are both SVR. 

 

 
 

 
Entering an Upgrade PIN 

 

The software can easily be upgraded to handle more employees by entering a new PIN.  To 

do this, go to Admin > Registration. 
 

 
 

The registration screen will then be displayed: 

• Overtype the old PIN. 

• Click Check and the facilities will change. 

• Click Register. 

• A message box will appear, Click OK to complete the Upgrade. 
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Closing the Software for the First Time 

 

On closing the program for the first time, Business Payroll will force a back up to be taken 
(standalone version only).  Click Ok to clear the message and the Archive and Restore screen 

will be displayed.  
 

   
 

 

• Click the Archive button to open the file dialog window. 

• Select the location to save the backup. 

• The File Name consists of Year-Date-Time, example Q2002-08-14@142051.arc. The 

file name can be changed. 
• Click Save to start the backup. 

• A counter will show the progress of the backup.   

• When complete click Ok on the message box and then click Close. 

 

The program will now exit. 
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Setting up a Company 

 
The first step is to enter up the company details:  

 

 
Open the company maintenance screen by 

selecting Company > Company 
maintenance from the drop down menus 

and the following screen will be presented. 

 

 
 
 

 
General 

General 

 

 
 

Overview: 

 
The General screen is used 

for setting up the company 
name and address.   

 
 

Company Details 
Click the Add New Button to add a new company record.   

 

Company Name and Address 
Under the General tab fill out the Company name and address details. These details will be 

printed on all the relevant reports including the end of year reports. 
 

Display Forenames 
Check this box if forenames are required to be displayed on the main screen in the Employee 

Explorer window. 

 
Staff Number 

If a staff number is entered when setting up an employee, it can be used to sequence the 
employee explorer window and associated reports.  The default length is set to a maximum 

of 14 characters but, if fewer characters are needed, changing the length here will make for 

neater displays and printing.  
 

Date Ceased Trading 
If a company ceases trading during the tax year, then the ceased trading date can be 

entered. This is necessary if the company’s end of year returns are to be filed early via the 
internet. 

 

Pressing the Undo button will completely remove all information entered on this screen. 
 

When this has been completed, click the Tax, NI and Pensions tab. 
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Tax, NI & Pensions 

Tax, NI & Pensions 

 

 
Overview: 

This section allows entry 

of company Tax and 
Pension details, it also 

allows the default NI 
method to be set so each 

new employee added will 

be calculated in this way 

 
 

Tax District 

From the Tax, NI and Pensions screen select the Tax District Number from the drop-
down list. 

 

 

If the number has not 

been previously entered, 
select the button located 

between the Number and 

Ref. 
 

 

 

 
Select Add New and enter 

the Tax District Number 

and District Description 
into the lower fields. 

Press Save then Close to 
return to the main screen. 

 
Scheme Type 

The scheme type selected, depend on the kind of employee’s in the payroll.   
If all employees on the payroll are paid pension only (No Basic Pay) then the scheme type 

should be set to Pension Only Scheme. 

In any of the employee are receiving Basic Pay the scheme type should be set as Normal.  
 

Company Pensions 
If the company is authorised to operate a company pension scheme, enter the employer’s 

ECON number  
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Default NI 

Select the way NI should be calculated. This will be used as the default for any employees 
added to the system.  This can be overridden if necessary when adding a new employee.  

 

 

 

Tip 
Setting the default NI method here will save time 

when adding new employees 

 
Table method uses the Inland Revenue tables and should be used if transferring over from a 

manual payroll.  Exact will calculate NI using a percentage method; both methods are 

acceptable by the Inland Revenue. 
 

Small Employer Relief 
If the company is classed as a small employer put a tick in the Small Employer Relief check 

box. This will then calculate and display the compensation on the IR Remittance Advice. 
 

End of Year Returns 

Where the electronic transmission of end of year data is available, enter the Permit Number 
for the company. 

 
Tax Reference Search 

Enter the tax reference of the company to be searched for. 

 
Contractor Unique Tax Reference 

Enter the UTR of the company. 
 

Accounts Office 
Enter the Accounts Office Reference and select Office location from drop-down menu. This 

must be entered for subcontractor efiling. 

 
 

  
 
Payments 

 

 
Overview: 

The payments section 

is used to enter 
company bank / 

payment details.  
Additionally the default 

pay frequency and 
calculation method can 

be set for each new 

employee. 

 

Bank Details 
If the company makes net payments through a banking system using Giro or a form of BACS, 

enter the company’s Bank Details by clicking Add New Bank. 
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Adding a new bank 

 

 

 

 
Click Add New and enter the Sort Code, Bank 

Name & Branch.  At any stage the Undo button 
can be pressed to clear all the details. 

 

Press Save to store the details then Close to 
return to the Payments Screen. 

 
If bank details are to be ammended, select the 

bank from the list, correct the information and 

click Save, then Close. 
 

 

To assign the bank details to the company, select the bank sort code from the drop down list.  

The Bank Name and Bank Branch will appear in the respective fields. 
 

Autopay / BOBS / Faxpay / Telepay  
 

If any of the banking interfaces to BACS are used, enter the appropriate reference numbers 

into the Autopay / BOBS / Faxpay / Telepay fields.   
 

A format for the BACS transmission must be selected from the dropdown list. 
 

Default Pay Details 
 

The default calculation type i.e. Net > Gross or Gross > Net can be selected here.   These 

settings will be applied to any new employees created, but can be altered in the employee 
screens. 

 
The default pay frequency i.e. Monthly/Weekly/Two-weekly etc can be selected here. These 

settings will be applied to any new employees created, but can be altered in the employee 

screens. 
  
Cash Net Pay Rounding 
 

For cash payments, enter the Rounding to be taken into account when calculating the Cash 
Analysis.  E.g. to round down to 50p enter .50  
 

Show BACS Header 
 

Check this box if a header is required on the BACS file output from the system. The BACS 
software provider can inform the correct setting. 
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Calendar 

Calendar 

 

 
Overview: 

Payslips dates for each 

individual company are set 
from this screen.  

 
 

 

 

Tax Week or Month 
 

Use the Tax Week / Tax Month lists to view the dates for the selected period. 
 

Payslip Date 
 

This date is printed on the payslip for earnings paid in the selected period. 

 
Pay Period End Date 

 
The end date for earnings paid in the selected period.  E.g. if paying a week-in-hand, then 

this date should be set a week prior to the payslip date. 

 
Setting Weekly Payslip Dates 

 
Important: The dates for the year must be set from the first period for the frequency e.g. 1 

for weekly, 2 for 2-weekly or 4 for 4-weekly.  Then by clicking Generate Weeks or 

Generate Months the dates for each period will be calculate automatically. 
 

Setting Monthly Payslip Dates 
 

• The monthly dates can be change individually by selecting the tax period from the 

dropdown list and entering the required date. 
• Or by selecting the first option a day of the month can be entered. Then by clicking 

Generate Dates the dates for each period will be calculate automatically. 

• By selecting the second option the monthly dates can be setup to be a specific day of 

each month e.g. the last Friday of each month. Click Generate Dates to calculate the 

date automatically.  
 

Accept all Dates 
 

It is required that the dates are verified, once they have been tick the Accept all Dates 

check box.  If this box is not ticked the program will not perform calculations and a warning 
message will be presented directing the user to the calendar screen. 
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Reports 

 

 

 

Overview: 
The reports option 

screen allows the 

customization of the 
information displayed 

on the payslip and 
various options for 

other reports.  

 

 

Payslip Options 
 

Single Payslip Per Page 

Check this to produce one payslip per page or uncheck to allow for two per page. 
 

Print Forename on Payslip 
This will display employees forename on their payslip. 

 

Show Pay Method 
When this option is checked the pay method e.g. cash, BACS etc will appear on the payslip 

 
Print Zero Net Pay 

Ability to print payslips with zero net pay. 
 

Display Boxes on Security Payslips 

Displays boxes around gross, net etc on Security Payslip. 
 

Windowed DHPZ1 
Formats address to top. Option for DHPZ1 type payslip only. 

 

Print Salutation 
Prints Salutation on payslip. 

 
Suppress Titles 

Do not display titles on the payslip. 
 

Show Holiday Entitlement 

Prints Holiday Entitlement on payslip. 
 

Show Employers Pension 
Print the amount of employers pension calculated. 

 

Other Reports 
 

Page Throw between Sections 
This option will put a blank page between the various sections of the report. 

 
Suppress Superceded Records on P11 

The P11 report shows any payment that has been saved for the employee; this includes any 

payments that have been back processed, which are denoted by a (S) for superceded.  
Checking this option will remove the superceded records for the report.  
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Suppress Title Shading 

Deselect to show title/header shaded on reports.  
 

Show Employers Cost on IR Remittance 
Totals employers cost on IR Remittance. 

 

Show Year to Date on IR Remittance 
Displays year to date amounts on IR Remittance report.  

 
Show Address on Payroll Labels 

By default only the employees name will be printed on the payroll labels.  Check the box to 

include the address on the label.  The software is formatted to print on Avery 7160 or 7161 
labels. 

 
Click Close to return to the main menu. 

 
 

 
 Division, Departments & GL Codes 

 

To Access the Division/Department/Location 
And GL Code options select Company > 

Division/Department/Location G/L Codes 
 

 

 
 

 

 

 

Overview: 
 

Divisions/Departments/Locations 
are used to divide employees 

into groups.  When applied to 

an employee the display and 
reports will be split according to 

these groups. 
 

G/L Codes 

Can be applied to any addition 
or deduction within the system. 

 

 
Adding an Entry 

• Select the company from the list on the left hand side. 

• Select the correct tab. 

• Click the Add New button. 

• Enter the name of the group or code. 

• At any time click Undo to clear the entry 

• Click Save. 

 

This entry will now appear in the list on the right. 
 

Deleting an Entry 
• Highlight the entry to be deleted in the right hand list. 

• Click Delete. 
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Applying Divisions/Departments/Locations to an Employee 

From the main screen, highlight the employee and then press the right mouse button. 
Choose Employee Maintenance from the context menu. 

From the General section, select the Division/Location/Department for the employee. 
Click Save. 

 

Employee Explorer Grouping 

The main employee list can be ordered from Company > Display Options.  From here the 

employees can be sorted into three levels. 
For more information on Display Preferences see Main Screen Overview. 

 

Applying GL Codes to Additions and Deductions 
See Additions and Deductions later in this section for more information on how to set up and 

apply G/L Codes. 
GL Code Reports are available from the Reports > Pay Period menu. 

  

 

 
Standard GL Codes 

Before any G/L Codes can be assigned to the pay elements they must set-up using the 
Company > Division/Department/Location G/L Codes menu option, see the previous 

page for more details on how to do this. 
 

 

To Access the Standard G/L Codes options 
select Company > Standard G/L Codes 
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The Select Company drop down list allows the user to choose the company to work with, 

as each company may have its own separate G/L codes. 
 

To assign a code to the pay element simply choose one from the dropdown list next to it. 
When all codes have been set, click Save then Close. 

 

 
 

 
Additions & Deductions 

 
To access the Additions and Deductions 

options select Company > Additions & 

Deductions 

 

 
 

 

 
Additions 

 

 
Overview: 

This screen is used for 
setting up new 

additions, and defining 

the relevant 
parameters, i.e. 

allowable for tax, NI, 
rate factors etc. 

 

 

 
Creating a New Addition 

 

• Select the correct company from the dropdown list. 

• Select the Additions tab. 

• Click Add New. 

• Enter a description for the addition e.g. Bonus. 

 
Subject To 

 
• Define the Tax, NI, Pen (Pension) and Gross Up parameters: 

• If the addition is subject to Tax and/or NI, place a tick in the relevant box. 

• To include the addition amount in a pension calculation, tick the Pen box. 

• Tick the Gross Up box to make the addition a Net Addition. 

 

Rate 
If a second rate of pay is required, or another addition such as a mileage allowance, enter 

the rate payable in the Rate field. 
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Rate Factor 

The Rate Factor is linked to the employee’s hourly rate and is normally used for overtime 
additions.  For example:  To enter an addition for double time the rate factor will be 2.0. 

 
GL Code 

A G/L Code can be assigned to the addition by selecting one from the dropdown list. 

 
Payslip Priority 

If required, the order in which the additions should appear on the payslip can be set here. 
 

 
Deductions 

 

 

Overview: 
This screen is used for 

setting up new 

deductions, and 
defining the relevant 

parameters, i.e. 
allowable for tax, NI, 

Pen etc  

 

Creating a New Deduction 
 

• Select the correct company from the dropdown list. 

• Select the Deduction tab. 

• Click Add New. 

• Enter a description for the deduction e.g. Loan. 

 
Allowable Against 

 

Define the Tax, NI, Pen (Pension) parameters: 
If the deduction is allowable for tax and/or NI place a tick in the relevant box, i.e. if the 

deduction needs to be taken off before Tax and NI are calculated, tick both the boxes.  
 

To calculate the pension amount before the deduction is taken off, remove the tick from the 

Pen box.  This is only applicable if the pension deduction has been set up as a percentage of 
the basic pay. 

 
G/L Code 

A G/L Code can be assigned to the deduction by selecting one from the dropdown list. 
 

Payslip Priority 

If required, the order in which the deductions should appear on the payslip can be set here. 
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Pensions 

 

To Access the Pensions options select 
Company > Pensions from the main screen. 

 

 
 
 

 

 

Overview: 
This screen is used to set 

up the pension details for 
the company. 

 

 

 

Adding a New Pension Fund 
 

• Select the correct company from the left hand list. 

• Click Add New. 

• Enter the name of the pension fund.  This will appear on all relevant reports. 

• Enter the Scheme Reference as is supplied by the pension provider.  If the scheme 

reference is unknown, then leave this field blank. 
 

A G/L Code can be assigned to this fund by selecting one from the dropdown list.   

 
SCON Number 

 
Each pension fund may have a COSR or COMP number, which needs to be entered here. If 

there is no code number assigned to the fund, ensure that None is selected. 
 

Inland Revenue Approved Pension Plan 

 
If the pension scheme is Inland Revenue approved then the box needs to be checked.  The 

pension provider will be able to supply this.    
 

Gross Less Basic Rate 

 
To calculate the pension deduction on the gross pensionable pay less the basic rate of tax 

this box needs to be checked.  NB: This method only works when calculating the pension 
deduction on a percentage of the employee’s wages. 
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Deleting a Pension Fund 

 
• Highlight the fund name in the right hand list. 

• Click Delete. 

 

 

 
Setting up an Employee 
After setting up a company you can now add employees. To do this, ensure the correct 

company is displayed on the main screen: 

 

 
 
 

 
Then click either the New Employee button (as 

shown above) or select Employee > Employee 
Maintenance from the drop down menus. 

 

 

    

Click the Add New button to start a new employee record. 
 

 

 
General 

 

 

Overview: 
The General screen is 

used to set up the 
staff number, gender, 

title, surname, 
forename and 

division/dept/location 

as required. 
 

 

 

General Information 

Enter the employee’s standard details including, surname, forename, title and department  
The gender setting is used to check various statutory entitlements (e.g. SMP) and also to 

create temporary NI numbers where the employee’s correct NI number is not yet available. 
 

Staff Number 
This field contains the employee’s staff number if applicable. The length of this field can be 

set from the Company Maintenance screen, up to a maximum of 14 characters.  
 

Personnel Database Name 

DIAMOND DISCOVERY Business Payroll will link with Personnel Manager, personnel system. 
This field will only appear if a link to the personnel database has been activated. Personnel 

Manager options are available under Admin > Personnel Manager > Link Status.   
 

Division/ Location/ Department 
These fields can be used to sort the employees in the Employee Explorer window and reports.   

These codes can be set from Company > Divisions/Locations/ Departments, G/L 

Codes menu option. 
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Student Employee 
For employees who have signed a P38(S) tick the P38(S) Signed check box. This will indicate 

to the Inland Revenue that the employee is a student who has paid no tax, when 
electronically filing the end of year return. 

 

CIS 
Check this box for subcontractors. This will self-populate the Tax Code to CT and National 

Insurance Number to X – Exempt from National Insurance.  
 

 

 

 
Personal 

 

 

Overview: 

This section allows entry 
of the employee’s 

personal information, i.e. 
address, date of birth 

etc. 

 

 

   
General Information 

This screen contains sections for entering the Employee’s Address, Marital Status, etc. 
The Date of Birth field is used to check that an incorrect National Insurance code is not used.  

If the National Insurance number is not initially known for a new employee the date is also 
used to create a temporary NI number. 

 

Email Address/Password 
Enter the email address and password protects it when sending payslips via email. The 

payslips will default to a pdf document. 
 

Payroll Status 

By default the status is ‘Active’, allowing all pay operations to be performed on the employee. 
‘On Hold’ excludes the employee from any automatic payroll processing. 

‘Leaver’ allows printing of a P45 Certificate.  This status excludes the employee from 
automatic payroll processing operations but will allow manual payment. 
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Selecting ‘Deceased’ from the list will trigger the screen 
on the right. This allows the user to enter a 

representative of the deceased for whom the P45 will go 
to. 

 

A final payment can be made by selecting the checkbox 
at bottom of screen. 

 
 
Holiday Hours? 

 

If the employee’s holiday entitlement is measured in hours tick the Holiday Hours? checkbox.  
If left un-ticked the holiday entitlement will be measured in days. 

 
Holiday Allowance 

 

The total amount of holiday entitlement should be entered here. 
 

Holiday Taken 
 

Displays the amount of Holiday Taken in this field, half days appear as 0.5. N.B holiday is 

recorded in Absence Recording via the Change button in the Open and Pay screen, please see 
‘Absence Recording – Holiday’. 

 
Directors NI 

 
If the employee is a company director, put a tick in the Yes box.   

The employee may opt to pay NI under normal rules, therefore the Apply Directors NI? 

should be unchecked.  
  

If the employee has been appointed a director during a tax year the start date must be 
entered so that the NI is calculated on a pro-rata basis.  If no start date has been entered, 

the date defaults to the start of the tax year. 

 
Date Left 

 
This date will appear on the P45 certificate. 
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Tax & NI 

 

 

Overview: 

This screen is used for 
inputting the employee’s 

tax code, P45 
information if required, 

NI Code letter and NI 

number. 
 

 

Tax Code 
 

This is a mandatory field and must be entered in one of the following formats without leading 
blanks or zeros… 

           1 to 999999H, L, P, V, T, J, A, Y (E.g. 461L, 264T, 1035H) 
           0T 

           K1 to K999999 

           BR, D0, NT (No Tax), CT (Subcontractors 18%) 
 

Tax Basis 
 

Wk1/Mth1 does not include the employee’s previous pay and tax in the pay calculation.  This 

is used, for example, when an employee’s P45 details are not available.  
Cumulative will include the previous pay and tax details in the pay calculation.  

 
Previous Employment P45 Pay & Tax  

 
Enter any P45 Gross Pay and Tax Paid from a previous employer during the current tax year. 

To check whether the previous employment details are correct click P45 Check. Select the 

pay frequency for this employee and the period for which the calculation is being made and 
then click P45 Check. If the P45 details are incorrect the Calculated Tax area will be shaded 

red. 
 

NI Code Letter 

 
Choose the correct NI code (NI Table Letter).  Note: - The system does not support mariners 

NI Table Letters. 
Various checks are made within the system to ensure that the correct code is used. 

E.g. if the employee is in a Contracted Out Money Purchase Scheme (COMP) then the NI 
code must be F, G or S. 

Warning messages will also appear below the selected NI code if an appropriate ECON or 

SCON number has not been entered in the company information.  These are required for 
printing on the Inland Revenue end of year tax reports and can be entered by using the 

Company > Company Maintenance menu. 
 

NI Number 

 
If an NI number is not provided then leave the NI Number text box blank.  The NI number 

must be entered as soon as possible as this information is required on all Inland Revenue and 
Contribution Agency reports. 
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IRPR Number (Inland Revenue Personal Reference)   

 
This number will appear on all documentation from the revenue and may eventually 

supercede the NI number.  
 

 

 
Pay Method 

 

 

Overview: 
The pay method section 

is used to enter the 
employee’s pay method, 

i.e. BACS or Cash and 
bank details if required. 

 

 

 

Pay Method 
Choose one of the pay methods from the list. For each pay method different reports and 

controls are available from the Reports > Pay Period > Payment Method Reports 
menu. 

 

Bank Details 
Start by entering the employee’s sort code, if the bank has already been added the Bank 

Name and Branch details will be completed automatically.  If there is no match the user will 
be asked to add a new bank, select Yes. 

 

Adding a new bank 

 

 

 

 

Click Add New and enter the Sort Code, Bank 
Name & Branch.  At any stage pressing the Undo 

button will clear all of the details. 
 

Press Save to store the details then Close to 

return to the Payments Screen. 
 

If bank details need to be amended, then select 
the bank from the list, correct the information 

and click Save and then Close. 

 

 
B/Soc. Role Number 

If the Bank Sort Code is for a Building Society then enter the Building Society Roll Number 

(maximum of 20 characters). This field is also used to add a reference to BACS files. 
 

Auto Banking Reference Number 
If either the BOBS/Autopay/Faxpay or Telepay pay methods have been selected, enter the 

employee’s BOBS/Autopay/Faxpay or Telepay reference. 
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Pay Rates 

The pay rates section (shown below) is used to enter details of the employees’ pay 

frequency, pay rate indicator, standard hours, if required, and pay rate. There is also the 
facility to choose the calculation type, SSP details, a student loan, and a pro-rata pay on start 

facility. 
 

 
 

SSP 
If the employee is allowed SSP tick the Allowed checkbox. 

Enter the Number of Qualifying Days in a working week that an employee would qualify for 
SSP payments i.e. this is the number of days in a week that the employee normally works. 

If the employee has been receiving other benefits, the Benefits Agency may have notified a 

date before which SSP cannot be paid.  If so enter the date. 
 

Pay Rates and Salaries  
 

Select the Add Rate button. 

 
 

 

The Pay Rate Indicator has been replaced with a Salaried Check-box and it reflects the way in 
which the employee’s pay is calculated. If Salary the employee’s basic pay will be calculated 

using the salary per week/month multiplied by the number of pay periods (e.g. two weekly = 
2). Hours per week can still be entered, but it will not be used in any pay calculations. 

 

Example 

 
 

 
 

 

 
 

 
 

 

Salaried Check-box 

 



 24 

Pay Frequency 

Always check when entering or changing the pay frequency that the Salaried Check-box, 
Standard Hours and Pay Rates fields are consistent with the changes. 

If an employee changes pay frequency, the same employee record can be used and all the 
pay details at the old pay frequency are retained and reported as normal. When the effective 

date changes mid-period, you will need to select a valid date from the drop-down list.  

 
The default pay frequency can be set from the Company > Company Maintenance, 

Payments tab. 
 

Start at Pay Period 

If the employee starts during the tax 
year, the starting period should be 

entered here. 

 

 
 

Student Loan 

Tick this box to deduct the loan 
repayment automatically. Dates can 

be entered for Start/Stop, although 

these cannot be back-dated. 
 

 
Select Save Rates once finished and 

then Save on the main screen. 

 

 

 
If your employee is a salaried, monthly paid employee, you will notice the Pro-Rata on 

Start button appear on bottom left of screen. 
 

Select the Pro-Rata on Start button. 

 
 

 

This will display the pro-rata options. 
Select the Pro-Rata Method. 

Enter the number of Days Worked in the 

period. 

 
If this is a new employee, complete the rest 

of the Employee Maintenance screen or 
select Save. 

 

 
 
 

Note: If a pay rate changes through a pay period, the basic amount will need to be manually 
changed for this period only. The new rate will appear as per normal the following pay 

period. 
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Additions 

 

 

Overview: 

From this screen, any 
additional payments 

made to the employee.  
The addition(s) will be 

applied to each and every 

pay period. 
 

 

 
 

Applying an Addition 
 

• Click the Add New Addition button. 

• From the dropdown list select the addition to add. 

• In the Amount/Hours field enter the payment to be made.  Please note you will only 

be able to enter Hours if the addition has been set up using a rate or rate factor. 

• Click Save Addition. 

 
If the Add New Addition button is not available, it means that there are no additions set up 

for the company. 
 

Deleting an Addition from the Employee 

 
• Highlight the Addition in the list. 

• Click Delete Addition. 

 

 

Creating a New Addition Type 

A new addition can be created in two ways: - 
 

Click on Company>Additions 
and Deductions. 

Click on the Add New button. 
Enter information as required. 

Click on Save. 

Or when in payroll 
Processing 

Click on Change. 
Click on Create Addition. 

Click on the Add New button. 
Enter information as required. 

Click on Save. 
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Deductions 

 

 

Overview: 

From this screen the 
user can add any 

deduction made to the 
employee.  The 

deduction(s) will be 

applied to each and 
every pay period. 

 
 

 

Applying a Deduction 
 

• Click the Add New Deduction button. 

• From the drop down list select the deduction to add.  

• Enter the deduction amount. 

• Click Save Deduction. 

 
If the Add New Deduction button is not available, it means that there are no deductions 

set up for the company. 
 

Reducing Balance Deduction 

 
If the employee has had a loan or has to pay a court order the total amount payable can be 

entered in the Starting Amount field. 
 

• Enter the amount to be deducted each pay period in the Amount field.   

• This amount will then be deducted each pay period until the loan\court order is paid. 

 
Deleting a Deduction 

 

• Highlight the deduction in the list. 

• Click Delete deduction. 

 
 

Creating a New Deduction Type 
A new addition can be created in two ways: - 

 

Click on Company>Additions 

and Deductions. 
Click on the Add New button. 

Enter information as required. 

Click on Save. 

Or when in payroll 

Processing 
Click on Change. 

Click on Create Deduction. 
Click on the Add New button. 

Enter information as required. 

Click on Save. 
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Attachment of Earnings Order 

 

 

Overview: 

This screen is used for 
attachment of earnings 

orders only.  
 

 

 

 
Operation 

Click the Add New AEO button to unlock the fields 
Using the information supplied on the AEO form, enter the details that are applicable. 

Click Save.  
 

Order Types 

PAEO -Priority AEO 
CPAEO - Consolidated Priority AEO 

NPAEO - Non-Priority AEO 
CNPAEO - Consolidated non-priority AEO 

AE on AOS - Attachment of Earnings on an Admin Order 

CCAEO - Community Charge AEO 
CTAEO - Council Tax AEO 

DEO - Child Support Deduction from Earnings order 
SEA - Scottish Earnings Arrestment Order 

SCMA - Scottish Current Maintenance Arrestment Order  
SCAO - Scottish Conjoined Arrestment Order 

 

For an information booklet on attachment orders please contact:  The Court Service, 
Southside, 105 Victoria Street, London, SW1E 6QT.   
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Pensions 

 

 

Overview: 

The Pension section is used 
to select a Pension Fund 

and scheme type from the 
list available.  Employee 

and employer values can 

then be entered either as 
an amount or a percentage.  

 
 

 

Pension funds 
To setup a pension Fund Name, go to the Company > Pensions menu.   

Each employee can make payments into a maximum of 2 pension schemes.  Other regular or 

variable deductions can be tailored as pension deductions by adding a deduction from the 
Company > Additions & Deductions menu, but only for pre-calculated pension amounts 

– in this case there would be no checking against the National Insurance code and the 
amounts would not be included in the Pensions Analysis report. 

There are restrictions on the Scheme Type such as.  E.g. an AVC must be entered as an 
Additional Pension Fund when the Main Pension Fund is, for example, an Occupational 

Pension scheme. 

 
Pension Amount 

Enter a percentage (to a maximum of 2 decimal places) if the %age box is checked; 
otherwise enter the fixed value to be deducted each pay period. 

If a percentage is entered it will be used to calculate the pension contribution from the 

Pensionable Pay for the pay period. Pensionable Pay is accumulated from those pay elements 
that have been defined as Pensionable.  To change these definitions use the Company > 

Additions & Deduction menu.   
 

Tick this box to only use the pay between the LEL and UEL in the pension calculation. 
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Adding a New Employee During the Tax Year 

If a new employee starts after the 12th April it will be necessary to change the tax period to 

the correct week/month.  The P45 details will be required and the employee’s tax basis may 

need to be changed. 
 

• Enter the employee as normal. 

• On the Tax & NI tab of the Employee Maintenance screen there are three areas 

relating to new starters Tax Basis, Previous Employment P45 Details and Starting 
Period. 

 

If the employee’s P45 Details are known 
 

 

Enter the details in the appropriate 
fields. 

 
If these figures need to be checked, 

then click P45 Check. Incorrect P45 

tax figures will be highlighted in red. 

 

If you do not have the employee’s P45 Details 

    

If no P45 details are available, a P46 form 
must be completed. 

Please refer to the Inland Revenue 
documentation E13 Day to day payroll for 

which tax code and tax basis to use. 

 
Starting Period 

• Enter the number of the first period to be paid through Business Payroll. 

• If unsure of the tax period use the calendar, which can be found under the Help > 

Tax Periods menu. 

 
Save and Close the employee record. 

 
Please Note 

When an employee has ceased working for the company, but later returns to the company 
after receiving earnings from another employment then a new employee record is required.  

Please read Duplicate Employee for a quick way to set up the new record. 

 
 

 
Duplicate Employee 

The duplicate employee function makes a copy of an existing employee’s data and is useful to 

quickly set up a number of employees with similar details e.g. There are new starters with the 
same basic pay and tax code.  It is also useful when a previously employed person has 

returned to the company. 
 

• Set up a basic template for the employee as per the Setting up an Employee section. 

• When the record has been saved select the employee by left clicking over their name 

to highlight them. 

• Select Duplicate Employee from the Employee menu at the top of the screen. 

• A new employee will be displayed in the employee list with the “new” appended to 

the surname. 
• The employee details can be amended by right clicking over the employee name and 

selecting Employee Maintenance.  
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Deleting an Employee 

To delete an employee completely from the payroll: 

 

• From the main screen, click the right mouse button over the employee’s name. 

• Select Delete Employee from the context menu. 

• Click Yes to continue. 

• Type the word “CONFIRM” on the keyboard. 

• Click Ok. 

 
 

 
Making an Employee a Leaver 

Press the right mouse button over the 

employee’s name and select Employee 
Maintenance from the context menu. 

 
 
 

 

In the Employee Maintenance screen, go to the 
Personal section and change the Payroll Status to 

Leaver. 
Enter the Leaving Date 

Click Save and then Close. 

 

 

 

The employee will now be highlighted in yellow and will 

be excluded from any automatic payroll processing. 

  

 
 

Printing a P45 
P45 Certificates can now be printed by clicking the right mouse button over the employee’s 

name and selecting: Employee Print > P45(1) Leavers Certificate, alternatively this 

option can be found under Reports -> Employee -> P45(1) Leavers Certificate on the 
main menu. 
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CIS – Construction Industry Scheme 

 

 
Employee Setup 

 

 

 

 

Overview: 

The setting up of a CIS 
employee is a matter 

selecting the 
Subcontractor check-

box on the General 
screen in Employee 

Maintenance. This will 

default the Tax Code 
to CT and the NI 

Number to X – 
Exempt from 

National Insurance. 

Continue setting the 
employee up as 

normal, then save. 
 

 
 

Entering Subcontractor Details 

This screen is filled out and submitted to the HMRC to confirm CIS details. 
 

 
To get to the below screen go Employee > Subcontractor, as 

shown to the right. 
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Select the Business Type. 

  

 

 
Enter Trading Name or 

Company Name, Unique 
Tax Reference & Company 

Registration No. 

 

 

Fill in the Partnership UTR 
and Partnership Name if 

applicable (Partnership 

Business Type only). 

 

 

 
The default option on checking 

details is Verify. Verify will 
be used if the minimum entry 

on the UTR section is the 

Trading/Company Name. 
Select Match only if all 

information is entered. 

 

 

ID Authentication should 

already be pre-populated from 
entering it on the FBI Setup 

screen. 
If the details are not entered 

please go to FBI > Setup or 
view how to in the File By 

Internet section. 

Save entered details. 

 

Below is an overview on the options available to select on this screen. 
 

 

Scheduling a submission allows you to verify at a time 
convenient. 

 

Print a copy of these details entered. 

 

Builds XML file to verify. 

 

Transmits XML file real time. 

 

Undoes entered details. 

 

Closes screen. 
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Saves entered details. 

 
Verify CIS Details 

 
CIS details entered must be verified. If verification does not confirm with the HMRC system 

files, the employee will be automatically put on a CTI tax code. This is the incentive tax code. 
 

If you have elected to Transmit 

Live, you will now be viewing the 
screen to right, allowing you to 

view the file it will send. 
 

To Schedule a Submission skip 

these steps. 
 

 

 

The URL address is built within the 
software and will not need to be 

changed. 
 

You can view this file again before 

sending by selecting View XML, 
and it can be copied to folder. 

 
Select Submit to verify with the 

HMRC. 

 
 
If the below error appears during submission, incorrect details are held in one or more of the 

following - Tax District Number or Reference in Company Maintenance. Agent ID (if you’re 
registered as an agent), Sender ID or Password in the File by Internet > Setup screen. 

 

 
 
 

Scheduling 
 

From the menu at top, select File By Internet > Schedule Submission, to view the below 

window. Highlight the CIS file from the left window and enter a Scheduled Date and Time. 
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Select the arrows button. 

 

 
The selected CIS file will now appear in the right window, as shown below. 

 

 
 
 

 

Now select the Activate Timer button. 
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This will start the process of submitting the 

CIS file. 
 

You will receive an email confirmation from 
the HMRC within 24 hours (as long as an 

email address has been entered on the FBI 

Setup screen). 

 
 

Note: Depending on your internet provider you may need to have an internet connection 

running before starting this process. 
 

 

 
Brought Forward Details 

 

 

Opening Brought Forward Details: 

Brought forward details can be accessed by selecting 

Employee Brought Forward… from Employee on the main 
menu. Alternatively it can be accessed via the Employee 

Brought Forward button found on the Employee Maintenance 
screen. 

 

 

 
Overview: 

This section is only used when 
converting from another payroll part 

the way through a tax year.  
 

 

 

Important: This screen is used only to enter Brought Forward information in situations 

where the payroll is being converted from another payroll system part way through a tax 

year. 
 

Entering Brought Forward Details 
The pay frequency for the employee must be set before entering any B/F details; this is set 

on the Pay Rates tab. 
To activate the screen click Unlock and the following warning message will be displayed. 
 

 

 

Please read this warning message before 
selecting Yes to proceed 
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Select the Week/Month of the period paid by the old system from the ‘As at end of Tax 

Week/Month’ dropdown list. 
 

This Employment 
• Enter the Gross pay to date, Tax able pay to date, Tax paid, Free pay and Net pay for 

this employment only.  If the employee joined the company during the year, the 

previous employment P45 details should be entered under Tax and NI tab of 
Employee Maintenance. 

• There are additional fields for SSP, SMP and Tax Credits etc.  Complete these fields 

as applicable. 

• There may be a rounding carried forward if a rounding has been applied to cash 

payments. 
 

B/F National Insurance   
Select the NI letter from the dropdown list above the leftmost column. Three columns have 

been provided for entering NI payments.  A separate column should be used for each NI 

letter the employee has had during a tax year.  
 

 
Important: All rows of the B/F National Insurance section should be filled out appropriately. 

Failure to do so will result in incorrect figures appearing on the P35 and the employee’s P60 
at the end of the year. 

 

 

Checking the Details 
When all B/F data has been entered use the Pay Summary, Company Totals and/or P11 

reports to reconcile to your previous system. 
 

 

 
Transfer Employee 

The transfer employee function copies complete employee records to another company, 
transferring all year to date information or marking the original record as a leaver. 

 
To access the Transfer Employee screen select the company that the employees are to be 

transferred from.  Now select the Company > Transfer Employee menu option. You will 

be presented with a list of employees in the selected company. 
 

 
Select the employees to be transferred. Holding down the CTRL key on the keyboard allows 

for multiple selections of employees – alternatively if all employees are to be transferred 
tick the Select All check box.   

 

 

The company to transfer to can be selected from the 
dropdown list.  Or by typing a name into the 

dropdown list a new company will be created.  
All additions, deductions and pension details can be 

copied by clicking the check box. 

 

Select Transfer all Year to Date 

Information if the employees pay records 
are to be transferred. Otherwise select 

Treat as Leavers and enter a leaving date, 
this will set the employees status to Leaver 

before transferring them. 
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If required, entering the correct starting period 

against the frequency the employee(s) are on can 
advance the starting period for the employee(s). 

 
Click Transfer. 

You will receive a message giving details of the transfer, click OK to proceed. 
 

 

 

 
Absence Recording 
Absence recording allows extended periods of absence for any employees to be set up; this 

includes SMP, SAP and SPP.  
 

To access the Absence Recording screen, 

select Employee > Absence 
Recording.  
 

Or click the  button on the main 
screen.  

 
Adding a new absence 

 

 

Select the employee from the Select 

Employee dropdown list at the top of 

the window. 

 

 

 
Click the Add New button. 

 

 
 

• Select the type of absence from the dropdown list. 

• Enter the required dates 

 
Expected: The expected date of birth (or adoption). 

Actual: The date the child arrives (generally used when the baby is premature). 
Leave Start: The date on which the employee intends their absence to start.   

Date Certificate Issued: This is only applicable by default to SAP.  SPP will require a date if 

the Adopted checkbox is ticked. 
 

 
 

Select the way the statutory payment should be made: 
Reduce Basic Pay by Statutory Amount:  This option will pay the employee their normal 

wage for the period, an apportioned amount of this pay will be statutory pay. 

Do not Pay Basic Pay: The employee will only receive statutory pay. 
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Pay Basic Pay as Entered: The statutory payment will be added to the normal Basic Pay. 

 

 

 

Click Save. 

 

 
If the payment should be stopped: 

• Go back into absence recording.  

• Select the employee from the dropdown list. 

• Tick the Entitlement Stopped checkbox and enter the stop date. 

• Click Save. 

 
 

On opening and paying there are instances when an employee’s pay details will need to be 
entered in order to calculate their average weekly earnings.  

 

 

If the employee has recently been entered 
onto the system then Business Payroll will 

ask you to provide pay details for the 
applicable earnings period. 

 

Enter the employee’s last payday prior to the 
date displayed (04/01/2003 in the example). 

 
Select the employee’s pay frequency from the 

drop down box. 
 

Enter the amount of pay that the employee 

received on this date. 
 

 

 

 
Upon entering the gross pay earned from the 

employee’s last payday you will be prompted 
to enter the gross pay earned by the 

employee between two dates (06/11/2002 

and 01/01/2003 in the example).  

 

 

 

Once you have entered all of the gross pay 
earned by the employee between the two 

dates given, the ‘Calculate’ button will be 

activated.  
 

Click Calculate and Business Payroll will 
display the average weekly earnings for the 

employee over the specified period.  
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Recording Holiday 

Before recording holiday leave, a Holiday Allowance must exist under the Personal tab of 

Employee Maintenance. 

 
Right click on the employee whom is on holiday from the employee list on the main screen 

and select Open and Pay Employee. Once the Open and Pay screen has loaded click on 
the Change button and then the Absence Recording tab. 

 

Click the Add New Absence button and select Holiday as the absence type from the drop 
down list. Amend the dates accordingly and enter the number of holiday days taken. Click 

Save Absence and then close the window. 
 

 
 

Note; this function is used purely to record holiday dates for reference purposes and will not 
calculate holiday pay automatically, if holiday pay needs to be applied then an addition must 

be created.  
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Bulk Amendments 

 

To access the Bulk 
Amendments options 

select Company > Bulk 

Amendments. 
From here you can then 

choose Holiday 
Maintenance or Bulk Pay 

Amendments. 

 

 
 

 
Holiday Maintenance 

From the Holiday Maintenance option you can reset and/or carry forward holiday allowances 
for all or groups of employees. 
 

Selecting a Group 

    

 

Click the left mouse button over the company 

name to amend the whole company. 
Or over the Division/Location/Department name 

to adjust just that group. 

 

Processing the Amendments 

 

From the Pay Frequency dropdown 
list you can elect to amend 

employees on a particular pay 
frequency. 

Select the way the holiday 

entitlement is measured.   
Enter the employee’s Entitlement in 

the Set Entitlement to field. 
If you would like the unused 

holiday to carry forward place a tick 

in the Carry Forward Entitlement 
checkbox. The Maximum Carry 

Forward field will become active.  
Here you can set a limit for how 

much unused holiday is carried 
forward. 

Remove the tick from the Clear 

Holiday Taken to leave the holiday 
taken unadjusted. 

 

Click Process to start the operation. 

A report will be produced giving details of the amendment.  Click Yes to view the report. 
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Bulk Pay Adjustments 

It is possible to alter the pay rates for all employees or groups of employees. 

  

Selecting a Group 

    

 

Click the left mouse button over the company 

name to amend the whole company. 

Or over the Division/Location/Department name 
to adjust just that group. 

 

Processing the Amendments 

 

 

 

• From this screen you can choose whether to Increase/Decrease the employee’s pay. 

• Select the relevant pay frequency using the Pay Frequency dropdown list. 

• You must also select the Pay Rate of the employees to change. 

• Adjustment can be made by a percentage, to do this, tick the Amend by %age 

checkbox. 
• Enter the Amount in the Amount field. 

• Click Process to continue.  

 

A report detailing the amendments will be produced.  Click Yes to view the report. 

 
 

 
 

 

 
 

 
 

 

 
 

 
 



 42 

 
Main Screen Overview 
The main screen offers an intuitive and functional interface that allows access to the core 

features of the system.   
 

 
Employee Explorer 

Selecting a Company to Work With 

 

 

The company to work on can be selected 

from the dropdown list.   

 
 

The employees within that company will 
appear in the employee list below.  

 

 
What the Symbols Mean 

 

 

:  The employee has been processed and 

the pay period is closed. 
 

:  The employee’s pay has been 
calculated but the period is still open. 

   

:  The employee has been loaded but not 
saved, this usually occurs when a calculation 

has been cancelled. 
 

:  No processing has yet been carried 
out. 
 

 
 An employee highlighted in red is On Hold. 
 

 
A Yellow highlighted employee signifies a 
Leaver. 

 
 

 

The letters and Numbers in Brackets 
The letters indicate the pay frequency: 

 
W = Weekly 

M = Monthly 

T = Two Weekly 
F = Four Weekly 

Q= Quarterly  
H= Half Yearly  

A= Annually 
 

The numbers show the last pay period processed for the employee.  This number 

automatically advances to the next period when Open & Pay is performed on a closed 
employee.  
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Display Preferences 

The way the Employee Explorer displays the information can be altered through the Display 

Preferences screen. 

 
 

The Display Preferences screen is accessed 
either by selecting Company > Display 

Preferences, or by clicking the Display 

Options button on the main screen. 

 
    

 

 

Divisions/Departments/Locations 

The employees can be split into their 

assigned Divisions/Departments/Locations 
by a three-tier system.   

For example: If you select Location for the 
first level and Department for the second 

the Explorer window will look like this 
 

    
Sort Sequence 
These three options will affect the staff 

order within the 

Locations/Divisions/Departments. 
 

Include Leavers 
Uncheck the box to remove leavers from 

the Explorer window. 
 

Always Expand Tree View 

Tick this box to show all levels in full. 
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Searching 

DIAMOND DISCOVERY Business Payroll now comes with the facility to search the employees 

using the search bar on the main screen. 

 

 
 

Using the Search Bar 

• Select what field is to be searched using the first drop down list. 

• Use the second list to refine the search. 

• Enter the search term for in the field to the right of the drop down boxes and then 

click Search. 
• The first employee who meets the criteria will be highlighted in grey. 

• By clicking Search (Next) again the next matching employee will be highlighted. 

 

A message will be displayed when all employees have been found. 
 

  

 
Payroll and Tax Calculator Modes 

All versions of DIAMOND DISCOVERY Business Payroll come with an offline PAYE and 
National Insurance calculator that can be used for checking P45 details and “what if” 

situations completely independently from the payroll. 

 

 
 
Switching Modes 

To switch from Business Payroll Mode to Payroll Assistant Mode or vice versa, click the payroll 
or calculator radio buttons.  This can be done at anytime; a message prompt will be displayed 

if it is possible to save data. 

Please see the Payroll Assistant section for more information on using the off-line calculator. 
 

 

 
Shortcuts 

The main menu contains shortcuts to several of the most widely used functions. These 
shortcuts are described below. 

 

  Exits the program. 
 

  Loads the most recent pay calculation for the highlighted employee. 
 

  Displays the open and pay employee window for the highlighted employee. 
 

  Closes off the pay period for the highlighted employee. 
 

  Opens the employee maintenance window for the highlighted employee. 
 

  Opens the absence-recording window for the highlighted employee. 
 

  Prints the payslip for the highlighted employee. 
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  Allows you to change the section viewed (Professional only). 

 

 

 

 

DIAMOND DISCOVERY Business Payroll also gives you 
the option to navigate directly to both the New 

Employee window and Display Preferences window from 
the main screen. 

 
 

 
Payroll Processing 
 

 
The Stages of Payroll Processing 

There are two stages to payroll processing: 

 
Open & Pay 

In this step a new pay period is opened, the employees pay is calculated and the results are 
saved to file.  The  symbol will appear next to the employee to show that this action has 

completed successfully. 

This action can be done as many times as you like i.e. if a bonus payment has been missed 
for an employee during the main payroll run, then Open & Pay this employee and apply the 

bonus. 
 

Close Pay Period 

It is normal procedure to run a Payroll Summary report before starting this stage to ensure all 
employee pay details are correct.  This report is found under Reports > Pay Period > 

Payroll Summary. 
The Close Pay Period function will finalise the pay period and put a  next to the employee 

to indicate this has been successful. 
By closing the pay period, valid payslips can now be printed and by selecting Open & Pay the 

period will automatically advance.   

Please Note: Closed periods can be re-opened using the Back Process option explained later 
in this section. 

 
Payroll Processing Symbols 

:  The employee has been processed and the pay period is closed. 
 

:  The employee’s pay has been calculated but the period is still open. 

   
:  The employee has been loaded but not saved, this usually occurs when a calculation 

has been cancelled. 
 

:  No processing has yet been carried out. 
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Processing by Company 

To process all employees on the same pay period and pay frequency: 

 

 

 

Click the right mouse button over the company 

name to display the Pay Action screen. 

 

 

Opening & Paying 

Select the required Pay frequency and 
Pay Period. 

Select Pay All. 
Click Continue. 

The  symbol will now appear next to 
the paid employees. 

 

Closing the Pay Period  
Right click the company name again to 

open the Pay Actions screen. 
The Pay period and Pay Frequency will be 

as before. 

Select Close All. 
Click Continue. 

A tick will be displayed next to the closed 
employees. 

 

Pay Frequency 
Select the Pay Frequency of the employees you wish to pay. 
 

Pay Period 

By default the next period to pay should appear in the Pay period dropdown box.  Any pay 
period can be selected but only a valid period will complete successfully. 
 

Actions 

Pay All calculates the wages and saves this information to disk.  

Close All finalises the payment for the selected period. 
 

Continue 
Clicking Continue starts the pay run.  When it has completed a message box will be 

displayed telling you how many employees have been Paid/Closed and how many have been 
rejected.  If there are any rejects an Anomaly report is produced.  

 

Anomaly Report 
If there are any errors, an Anomaly report is produced listing the employees where the errors 

occur and why. E.g. the employees have been paid and closed for period 1, you then try to 
Pay All for period 10.  This action will produce an Anomaly report informing you that the 

employees have not been paid for periods 2 – 10.  
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Processing by Division/Department/Location   

To process by Division/Department/Location the display options must be set up so as the 

Employee Explorer displays the employees under their respective headings.  For more details 
on how to do this see the section on Display Preferences. 

 
Division/Department/Location Processing 

 

 
Click the right mouse button over the division 
name to display the Pay Action screen. 

 
 

 
See the previous page Processing by Company for details on how to use the Pay Actions 

Screen. 
 

 

 
Processing an Individual Employee 

Individual processing can take place after the main payroll run to make any adjustments to 
pay, to do this: 

 

 

 
 
 
 

 

Click the right mouse button over the Employees 

name to display the context menu. 
 

 

 

 

 

 

Click the left mouse button over Open & Pay 
Employee; this will display the Payroll Processing 

section. 

 
 

 
The Payroll Processing section can also be displayed by clicking the left mouse button over 

the employee, then clicking  on the main screen. 
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Payroll Processing Screen Overview 

 

 

 

 
Basic Pay 

If Basic Hours and Basic Rate or Basic Pay have been set up they will appear automatically, 
but can be altered by overtyping them if necessary. 

 

Change 
Clicking the Change button opens a new screen that allows you to apply variable pay 

elements to the employee’s pay.  These changes only apply to this particular payment.  
Regular additions and deductions are set-up through the employee maintenance screen.  

 
Additions and Deductions 

These fields show the total additions and deductions applied to the employee’s pay. 

 
Restore 

Clears all additions and deductions and resets the Basic Pay.  
 

National Insurance Contributions 

 

NI Code 
This list displays the current NI Code for the employee.  The 

code can be changed through the Employee Maintenance 
screens. 

 
B/F NI  

Click the B/F NIC button to view the NI details for the 

employee.  The figures can be set to zero if the employee 
becomes a director. 

 
Director 

If the employee is a director there will be a tick in the Directors? box.  To make an employee 

a director, use the Employee Maintenance > Personal screen. 
 

NIC Refund 
It is possible to refund NI should the incorrect code have been used in previous calculations.  

The refund amount will be reflected on the IR Remittance Report.  Please see the Refunding 

NI section later in the manual. 
 

Tax for Monthly        Tax for Weekly 
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Tax Code 

Any changes to the tax code will be made permanent when the calculation is saved. 
Wk1/M1 

Tick this box to put the employee’s tax onto a week1/month1 basis.  A Wk1/M1 basis does 
not take account of Gross Pay to Date and Tax Paid to Date within the tax calculation.  This is 

normally applied when you have no P45 details for a new starter. Any alteration will be made 

permanent.   
 

Payslip Date 
The payslip date can be adjusted within the current pay period. Any invalid dates will not be 

accepted.  Changes to the date will not be made permanent. 
 

Tax at Period 

This is the Tax at Week or Month that will be used in the calculation.  This can be advanced, 
for example, when you have a new employee starting during the tax year or when paying 

holiday pay. 
 

Pay at Week 
Pay at Week is used for paying holiday pay in advance.  Please see Paying Holiday Pay in 

Advance later in this section. 
 

Pay Weeks 

If you are paying holiday pay in advance the total number of weeks’ pay will be entered here.  
This ensures the correct tax and National Insurance contributions are paid.  Paying Holiday 

Pay later in this section describes this operation in more detail.  
 

P45 Pay and Tax 

  
 

Taxable Gross and Tax Paid 
If any P45 details have been entered for the employee they will be displayed here.  These 

details cannot be altered here, but can be changed through the Employee Maintenance 
screen. 

 

Tax Paid this Employment 

 
 

Taxable Gross and Tax Paid 
These figures are accrued over the year and can only be altered by reprocessing the 

employee’s pay. 
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Performing a Calculation 

Ensure the details are correct, i.e. basic pay, tax week/month and that any additions or 
deductions have been applied. 

Click Calculate. 
The results will be displayed on the right of the screen. 

 

 

A more detailed set of results can be obtained by clicking the 
More Info button. 

 
Gross Pay 

The first tab on the More Info screen splits down the gross 
pay into Taxable\NIC’able and Non-Taxable\Non-NIC’able 

elements. 

 
Deductions 

This tab gives details on pension deductions as well as 
normal deductions and student loans. 

 

NIC 
The NIC tab gives a breakdown of both Carried Forward and 

Brought Forward NIC payments. 
 

Tax 
The tax analysis shows all elements of the tax calculation 

including a C/F breakdown. 

 
An Audit report can be printed by clicking the Print button in the results section. Should you 

need to make any adjustments, simply make the alteration and click Calculate. 
 

If you are happy with the calculation click Save to return to the main screen, or click Save 

Next to save this record and open the next employee for processing. 
 

To cancel the calculation click Cancel, you will then be asked if you wish to save the record.  
Click No to quit without saving.  

 
 

 
Multi Period Processing 

DIAMOND DISCOVERY Business Payroll comes with the facility to process multiple periods 

with a click of a button. 
 

Open and Pay employee, then click the Multi Period button to display the Multi period 
screen. 
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• Select the start and end periods for 

the calculation. 
• Click Calculate. 

• When all periods have been 

calculated click Save. 

• This process will calculate all pay 

elements so that all reports are 
available for printing. 

 

 
 

NB: The same pay details are used for each period calculated 
 

 

 
Refunding NI Contributions 

If an employee has been calculated using an incorrect NI code letter then it is possible to 
refund any NIC that is due. 

 

• Firstly, correct the employees NI code letter, which can be found in Employee 

Maintenance > Tax & NI. 
• Pay the employee by right clicking over their name and selecting Open & Pay. 

• Click the NIC Refund button. 

 

Manual NI Refund 
 

Select Enter Manually from the Refund Options. 

 

 
 

• Select the NI code for which the NI 

contributions need to be refunded. 

• Enter the amount of employees NI 

to be refunded 
• Enter the amount of employer NI to 

be refunded. 

 

Click Save then Close. 

Click Calculate and the refund will be shown in the results section. 
 

 

Re-Calculate NI Automatically  
 

Select Re-Calculate from the Refund Options. 
 

 
 

The Apply NI Code field will show the NI 
code that will be used for the back 

calculation.  It is important that the NI 

code has been changed in Employee 
Maintenance prior to carrying out the 

operation. 
Select the period that the NI code should 

have been changed. 

 
Click Save then Close. 

Click Calculate and the refund will be shown in the results section. 
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Pay Period Additions & Deductions 

Click on the Change button to bring up the Pay Period Additions Deductions screen.  Please 

note any changes here will only affect this pay period. 

 
Applying an Addition 

 

 

Click the Add New Addition button. 

 

 

 

From the dropdown list select the 

addition to add. 
 

 

 
 

In the Amount/Hours field (highlighted in blue), enter the payment to be made.  Please 
note you will only be able to enter Hours if the addition has been setup using a Rate or 

Rate Factor. 

 

 

Click Save Addition. 

 

 
 

Applying a Deduction 

Ensure that the deductions tab is selected; the deduction is then applied as per the additions 
instructions. 

 

Making Adjustments 
Should you need to make an amendment to the Addition/Deduction. Highlight the entry in 

the list, which will populate the fields below with information.  Make the alteration and click 
Save Addition\Deduction. 

 
 

 
AEO Information 

This tab allows you to check the deduction amount and type of order attached to the 

employee.  
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Pay Period Absence Recording 

Click on the Change button to bring up the Pay Period Additions Deductions screen and then 

select the Absence Recording tab. Please note, any changes here will only affect the current 

pay period. 
 

 
 

 
Entering a new Absence (Sick Leave) 

 

 
 

Click the Add New Absence 
button. 

 

Select Sick Leave from the 

dropdown menu. Depending on 

the type of absence selected, 
different options will become 

available. 

 

 

 
Enter the dates that the employee 

was sick. The date entered in the 
finish date is included as a day off 

sick. 

 

If this is the first sickness recorded on the system and the employee has had previous 

sickness; refer to the Inland Revenue documentation to ensure that the correct number of 
waiting days has been calculated.   
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The number of Qualifying Days 

used in the SSP calculation can be 
changed. Qualifying Days are the 

number of days that the 
employee works in a normal 

working week. 

 
 

 
  

In some instances the Average 

Weekly Earnings must be entered. 

If the system doesn’t hold enough information to calculate the Average Weekly Earnings 
automatically, you will be asked to enter the Average Weekly Earnings for the eight weeks 

prior to the absence. 
  

 
 

The way in which the final pay is 

calculated is dependant on the 
option selected here. 

 

 

When all the details have been 

entered click Save Absence. 

  

 

After saving, each absence 
entered will appear in the list.  If 

alterations need to be made to an 
entry, highlight the absence and 

make any required adjustments. 

One the adjustments have been 
made click Save Absence.  

 

Other Absence Types 
All other absences are recorded using the same method. Average Weekly Earnings for SMP, 

SAP and SPP may be required, in which case enter the figure accordingly.  

 
Please note that with respect to SMP, SAP and SPP; the pay period absence recording 

section is used only to record the dates of absence and will not calculate statutory pay. For 
full automation of SMP, SPP and SAP the absence must be set up in Employee -> Absence 

Recording. See Absence Recording for further details.    

 
Manual Statutory Payment Entry 

Manual entries will override any other absence. 
 

 

 
Highlight the date range to be 

altered. 
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To calculate SSP from a number 
of days. Enter the exact number 

of days to be paid in the SSP Days 
field and click Calculate SSP 

from days.   

 

Use the Basic Pay Adjustment options to apply adjustments to the final calculation. 
Click Save when all the details have been entered.  

 

 

 
 

 
Student Loans 

 

 

Student Loans can either be calculated by 
manually entering an amount in the Pre-

calculated Amount field. 

Or automatically by ticking the Calculate 
box. After the changes have been applied 

click Save Student Loan. 
 

 

 
Pay Period Pensions 

A pension Fund Name must already be setup before adding a pension deduction; this can be 
done by going to Company > Pensions.  See Setting up a Company for more details. 

 

 
 

Pension Fund 
• Select the Fund Name from the dropdown list. 

• Enter the Employee Scheme Reference. 

• Select the Scheme Type. 

 

Pension Amount 

By ticking the %age box a percentage can be entered to a maximum of two decimal places. 
If a percentage is entered it will be used to calculate the pension contribution from the 

Pensionable Pay for the pay period. Pensionable Pay is accumulated from those pay elements 
that have been defined as Pensionable – to change these definitions use the Company > 

Additions & Deduction menu.  
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Click Save Pension. 

 
 

 
 

 

 
 

 
 

 

 
 

 

 
Processing Holiday Pay in Advance 

To pay holiday pay in advance the basic pay must be altered to include the whole amount or 
a further payment must be included in addition to the basic pay. To add holiday pay as an 

additional payment please see Pay Period Additions and Deductions earlier in this section. 
 

 

Change the Tax at Week to the last week of 

holiday pay. 
Change the Pay Weeks to the total number 

of weeks paid.  This ensures the employee 
pays the correct tax and NI. 

Pay at Week is the period the holiday pay is 
paid in. 

 

In the above example:  
The employee is currently on tax week 11. 

They are going to receive 1-weeks’ normal pay and 1-weeks’ holiday pay. 
The Tax at Week is advanced to 12, the last week of holiday. 

The Pay Weeks is changed to 2. 
 

 

 
Net to Gross Calculation 

To perform a Net to Gross calculation, the employee has to be setup in the Employee 

Maintenance > Pay rates.  
 

 

Instead of using the Basic Pay field, a new field in the 
bottom right of the screen marked Target Net Pay 

should be used. 

 
Click Calculate and the Basic Pay will be worked out automatically. 

 
 

 
Back Processing an Employee 

 

It is possible to re-open closed pay periods by using the Back-process option.  This process 
will supercede any previously saved data. 
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Highlight the employee in the list by clicking 
the left mouse button over the name. 

Select Employee > Back-process from the 
main menu. 

 

 
 

 

 
Use the Starting Tax Period to select the 

period to re-open. 
Read the warning message before clicking on 

Ok to continue. 

The employees name will now have a Yellow 
and Red symbol next to it in the employee 

viewer on the main screen. 

 
 

After back-processing an employee there are 
two options to re-calculate; Open & Pay 

Employee to restart the pay period or Load 

Employee to reload the pay details for that 
pay period. The payroll-processing screen will 

then be displayed. 
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Reports 
 

All reports available within DIAMOND 

DISCOVERY Payroll are accessed from the 
Reports menu.  These are then divided into 

their relevant groups. 

 
 
 

 
Reports by Company 

To print a report for all of the employees within a company: 
 

 

• Click the left mouse button over the 

company name to highlight it. 

• Go to the reports menu and select the 

required report. 
 

A Reports Option screen will then be 

displayed, which is explained later in this 
section. 

 
 

 

 

 

 
Reports by Employee 

Some reports can be printed for an individual employee: 
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• Click the left mouse button over the 

employee’s name to highlight them. 

• Go to the reports menu and select the 

required report. 
 

You will be presented with the Reports Option 
screen, which is explained later in this section. 

 

 
 

 

It is also possible to print some employee 
reports by pressing the right mouse button 

over the employee’s name and selecting 
Employee Print. 

 

 
 
 

 
Report Options 

The report options will change depending on the type of report that is being printed. 

 
 

 
 
Please note: Not all the options are available with every report.  Any options that are not 

applicable cannot be accessed. 
 

Grouping 
Some reports give have the option to sort by Division/Location/Department.  To do this 

simply select the group required from the Group by Level dropdown boxes. 

 
Pay Frequency 

Reports can be adapted to only include employees on the same pay frequency.  If it is 
necessary to print the report to include all employees, tick the Include all Pay Frequencies 

check box. 
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Tax Period 

A single period or range of periods can be reported using the Start and End period drop down 
lists.  If the Include all Pay Frequencies check box is ticked there will be no way to choose the 

pay periods to report as all periods are selected by default. 
 

Include Leavers 

Check the Include Leavers box to include leavers on the report. 
 

Exporting 
This is covered in more detail later in this section. 

 

Audit Reports and Payslips  

 

When printing Payslips and Audit 

Reports an additional field is 
displayed so that a message may 

be entered.  
If the report is run by company 

the same message will appear on 

each page in the batch.  

 

Align Printer 

 

The print position can be adjusted by clicking 

the Align Printer button. 
 

To adjust the printer, use the drop down lists 

to select the degree of adjustment. 
 

Click Save. 
 

The alignment settings will be saved for that 

particular type of report, so each report can 
be aligned independently. 

 

Test Print 
By clicking the Test Print button the selected report will print with X’s or 9’s in all fields of 

the report.  This is useful for aligning the printer.  
 

 

 
Printing Payslips 

 
 

To print payslip reports, select 

Payslips from the Reports 
menu and the following 

screen will be displayed.  
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Select the type of payslip required by using 

the radio buttons and then click OK.  The 
Selection Criteria for Payslips window will then 

be displayed; see Report Options. 
 

Please note that the Sage payslip formats are 

not yet accessible. 

 
 

Setting the default Payslip Format  
 

 Select the Company Maintenance option 

from the Company menu. 

 

 

 
 
Go to the Reports tab and select the required payslip type in the Default Payslip Type. 

Click Save and Close.   
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Emailing Payslips 

 

 

Please note: Third Party Software is required to be able to email payslips. 
A copy of eDocPrinter PDF Pro can be purchased from http://www.iteksoft.com/ . 

 

 

 

 
 

After the installation of eDocPrinter two new printers will be present in Printer Properties, 
eDocPrinter PDF Pro and ERP2PDF. 

 

Set the properties of the printer that is to be used. In 

the General section click Printing Preferences.  
 

 
 
Under the Links tab of Printing Preferences place a tick in the Enable detecting embedded 

commands check box. If the box is left unchecked then no .pdf files are created and nothing 
will be emailed. 

 

In the Email section, select Send the 
generated PDF file as email attachment 

and Send silently through default email 
client. 

  
 

 

 
 
For every payslip that is emailed via Business 

Payroll, the default mail client will display a 
warning message advising that another 

program is trying to access email addresses. 

If the payslips are to be emailed then click 
Yes when each message appears. 

 

 
 
If there are a large volume of employees for whom payslips are being emailed then this 

message will appear for each payslip. In this case a program called ClickYes can be 
downloaded to handle the action of clicking Yes. 

 

ClickYes can be downloaded from http://www.contextmagic.com/express-clickyes/ . 
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Go to Company > Company Maintenance from the main menu. In the Reports section, 
set the company Email Address, the Email Password. From the Default Payslips Type drop 

down list, select Payslips QC01. 
 

 
 

Before printing payslips select the eDocPrinter PDF Pro printer from the Printer Settings 
screen, under the File > Printer Setup menu. This will email all of the payslips as a single 

.pdf file to the email address stated in the company Reports section. 

 
A .pdf file containing the emailed payslips will be created in the folder where the DIAMOND 

DISCOVERY software is installed. 
 

 

 
 
Go to Company > Company Maintenance 

from the main menu. In the Reports section, set 
the option to print a single payslip per page. 

 

 

 

 

Go to Employee > Employee Maintenance from 

the main menu. In each employee’s Personal section, 
set the email address and password that will be used 

to open the file when received. 
 

 
Before printing payslips select the eDocPrinter PDF Pro printer from the Printer Settings 

screen, under the File > Printer Setup menu. This will email each employee’s payslip to 
their email address. 

 
A .pdf file will be created for each employee payslip in the folder where the DIAMOND 

DISCOVERY software is installed. 

 

 

Please Note 
If payslips are intended to be emailed to employees, then either ALL employees must have an 

email address, or the employees must be split into two departments or locations. When 

selecting the email section to print payslips, select the eDocPrinter printer and when selecting 
the print section select the normal payslip printer. 
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Previewing Reports 

When all the Report Options have been selected, click Preview and the report viewer will 

appear.   

 

 
 

 Report Controls 
 

  
Print 

 

 

Clicking this button will print the entire report. 

  
Search 

 

It is possible to search for any characters within 

the report. 

  
Toggle Tree View 
 

Click the Toggle Tree View button to show\hide 

the Tree View.  The tree view allows pages to be 

skipped within the report.  
 

  
Zoom  
 

Select the Zoom required from the dropdown list 

 
 Page Selection 

The main white field shows the current page, the 
number to the right shows the total pages.  The 

arrow keys to the left and right allow for scrolling 

through pages of the report.  
 

The Report Viewer can be closed without printing by clicking the  button at the top right 

corner of the report window.  
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Exporting Reports 

It is possible to export all reports in to various formats.  To do this:  

 

Select the report to be printed\exported: 
 

 

Tick the Export check box on the Report Option screen. 

 

The Report Viewer will appear, click the  button to print or  close the window.  
 

 

From the Export screen you can 

choose which Format to export 
the report in. 

 
The destination of the file then 

needs to be selected, which 
include email or to disk. 

 

Click Ok to continue. 

 

 

From this screen select to export all of the 

report. 
 

By selecting Page Range a certain section of 

the report can be exported. 
 

Click Ok to continue. 

 

The next screen shown depends on the destination chosen: 
 

• Disk File:  will ask for you to specify the location to save the file on disk. 

• Application:  opens the application related to the format type; e.g. PDF format will 

open Adobe Acrobat Reader. 

• Microsoft Mail:  opens a new email with the report attached. 

• Exchange Folder:  allows you to save the report into any Microsoft exchange folder 

available to you.  
• Lotus Domino:  exports the report to a Lotus Domino database. 

 

 

 
Additions & Deductions Report Options 

The Additions and Deductions Analysis Report allows either all the pay elements or up to 5 
individual elements to be selected from the list. 
 

• Select the Individual Pay Elements 

• De-select the Select All check box. 

• Tick the boxes next to the Additions and Deductions you wish to report. 

• Click Ok. 
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IR Payment 
Business Payroll allows payments to be made to the Inland Revenue via the internet. Select 

Company on the main menu and then IR Payment. 
 

 

 

Selecting Information on Making 
Payments, Payment of PAYE and 

Paying By Debit Card will open 
Internet Explorer and load the 

relevant page of the Inland 
Revenue’s web-site. Details are 

provided on how to make payments 

electronically. 
 

N.B. An internet connection is 
necessary in order to use these 

functions. 

 

Pay IR by BACS 

 
Only companies that have Accounts Office Reference, Bank Details, a BACS File Format and a 

Calculated IR Remittance value for the selected period will be displayed. Companies that have 
already had their payments made will not be displayed. 

 

 

 
The Pay IR By BACS screen will list Company, 

Calculated amount and Override amount (if 
entered on EOY Totals screen). 

 
Highlight company and click the Create File 

button. 

 Confirmation will be displayed and a text file 

will be created in the Diamond Discovery 

application directory, titled ‘<company 
name> IR Payment <period>.txt’ 

 The EOY totals will show amount paid to the 
Inland Revenue. 
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Diamond Discovery Payroll Assistant 
All versions of DIAMOND DISCOVERY Business Payroll come with an offline PAYE and 

National Insurance calculator that can be used to check P45 details and “what if” situations, 
completely independent from the payroll. 

 

Switching Modes 

 
To switch from Payroll mode to Calculator mode or vice 

versa, click the Payroll or calculator radio buttons.  This 
can be done at any time, if information needs to be saved 

then a prompt will appear. 

 

 

 
Calculation Options 

The calculation options can be chosen from either: 
 

 

The dropdown Lists at the top 
of the main screen. 

 

Or from the calculator menu. 
 

 
 

Please Note: If you have the 10 Employee version of the software, calculations can only be 

processed for the current tax year. 
 

 

 
Making a Calculation 

 

Use this section to enter the pay 

details. 
Click the Change button to add 

any Additions, Deductions, and 
SSP etc. 

The Restore button will clear 

all pay elements to zero. 

 

The Addition and Deduction fields show the total additions and deductions applied to the 

employee’s pay, but do not include WTC’s, Student Loans and percentage pensions as this is 
calculated during the pay calculation. 
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Enter the tax code and select 

the tax basis. 
Select the tax period and payslip 

date. 
If required, brought forward NI 

details can be entered by 

clicking the B/F NIC button  

 

 

When the pay frequency is set to weekly an extra field relating to 

holiday pay becomes available. Paying holiday pay in advance is 
covered in the Payroll Processing section.  

 

 

Enter the Taxable Gross & Tax Paid 

for the employee, if required there 
are two additional fields for P45 

details.  

 

When all of the details have been entered, click the Calculate button at the bottom of the 
screen. 

 

The results will be displayed to the right of the screen.  If more detail is needed click on the 
More info button. If a re-calculation of the same period is required, change the pay details 

and click Calculate again.  
 

There are several options in proceeding after a calculation has been made: 
 

 

• Save the calculation to file. 

• C/Fwd, carry forward the details to the next pay 

period. 
• Print either a Calculation Audit Report or Payslip 

Report. 

 

 

 
Calculator File Operations 

Saving a calculation 
 

Click the Save button. 

 
A prompt will appear asking for a calculation name. Enter a file name and click Ok. 

 

 

The file name chosen will be displayed in the 

employee list to the left of the screen and the 

calculator will be reset. 

 

Loading a Saved Calculation 

Display the context menu by clicking the right mouse button over the employee’s name in the 
list. From this menu select Load Employee. 

 
Deleting a Calculation 

Display the context menu by clicking the right mouse button over the employee’s name in the 
list. From this menu select Delete Employee. 
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Net to Gross Calculations 

To carry out a Net to Gross calculation: 
  
Select Net to Gross from the drop down list.  

 
 

 

A Target Net Pay field will be displayed in 
the bottom right of the screen. 

Enter the Net pay figure and click 

Calculate. 

 

The Basic Pay, Tax and NI will be calculated automatically. 

These results can be Saved or Carried Forward by selecting the appropriate action, (discussed 
in Making a Calculation). 
 

Tax Rebate 

 

The tax field will look like this when paying 
a rebate. 

 

 

If the rebate is not to be paid then remove 
the tick from the pay rebate check box.  

 
Click on Calculate. 

 

 

 
P45 Checker 

Select P45 Check from the dropdown lists. 

 
 

Select Pay Frequency from the drop down lists. 

 
 

  
 

Enter the Tax Code, Tax Period and P45 details. Click Calculate. 
 

 

The amount of tax paid will be displayed in 
the Calculated Tax field. 

 

Click Next to perform another check. 
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End of Year Totals 
To produce an accurate P35 Summary it is necessary to enter any funding and CIS 

deductions that are applicable to your business.  This can be accomplished through two areas 
of the software; either on a month by month basis through the Reports > Pay Period > IR 

Remittance Advice > Enter EOY Totals menu option, or for the year by selecting the File 

by Internet > EOY Totals menu option.   
 

 

 
Entering EOY Totals by Period 

 
 
Select Month 

Use the dropdown list to select the month in which the details need to be added. 
 

IR Funding 

If funding has been received from the Inland Revenue, then the amounts must be entered 
into the system within the appropriate fields. 

 
• Tax: Tax refunds. 

• SSP/SMP/SPP/SAP: Statutory Payments. 

 

Payments and Deductions 
Incentive Payment Received: If the company’s P35 was filed electronically in the previous tax 

year, then the employer may qualify to receive an incentive payment from the Inland 

Revenue. This is provided that the employer qualifies as a ‘small employer’ and a ‘full and 
complete’ submission was made. If the incentive payment is to be recovered from the Inland 

Revenue through the payroll, then the amount to recover should be entered in the relevant 
period.  

CIS Deductions: This field should be used by Limited companies who have suffered CIS 

deductions and must enter the value from form CIS25. 
Tax Deducted from Subcontractor Payments: Enter the tax deducted from subcontractors if 

applicable. 
Payments made to Inland Revenue: Enter the actual amount paid to the Inland Revenue for 

the monthly remittance. 
 

 

 
Entering EOY Totals for the Year 

All totals for the year can be viewed and amended by selecting File by Internet > EOY 

Totals. 
 

In addition, this screen shows the Compensated and Recovered statutory payment details. 
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File By Internet 
 

 
Preparing Business Payroll for File By Internet 

 

Select the Setup option from the File By 

Internet menu. 
 

 

 
 
Authentication Details 

 
On the set up screen enter the Sender ID and Password (these are obtained by registering on 

the Inland Revenue’s website, www.hmrc.gov.uk) and a valid email address. If the returns 

are being filed as an agent, tick the Agent Required check box and enter the details of the 
agent. 

 

 
 

Click Save and then Close to return to the main screen. 
 

Company Contact 

 
Select Company Maintenance from the Company menu. 

 
If the end of year return is being made as a company, then enter the company’s contact 

details in the FBI section. If the return is being made as an agent, then enter the company 

whose returns are being transmitted electronically. 
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Sending a Single Part FBI Submission 

 
Before attempting to submit any end of year returns, please ensure that Business 

Payroll has been set up for FBI, as discussed in the previous section. 
 

Data Validation 

 
Select Submit to HMRC from the File by 

Internet menu. 
 

 
 

 

The FBI submission screen will then be 

displayed. Confirm that the authentication 
details are correct and click OK.  

 

 
Business Payroll will validate that all of the required information has been completed. If the 

company passes the validation then the P35 Declaration screen will be displayed. If company 
information fails the end of year validation then a report will be generated detailing any fields 

that must be altered. 
 

P35 Declaration 

 
Complete the Declarations, Checklist(1) and Checklist(2) sections of the P35 Declarations 

screen, selecting any options that are applicable to the company. 
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The Tax & NI, Statutory and Totals sections display any information that has been entered 
via EOY Totals during the course of the year. If required, the figures can be either entered or 

adjusted within these screens.  

Once completed, the P35 can be printed by clicking Print. 
 

There are several options when submitting the return to the HMRC: 
1. Preview the submission by clicking Build XML and click Yes when asked if a preview 

of the XML is required. This will make the selected company available for scheduling 

to submit at a later time. The XML files can be built for any number of companies, 
working through the list in the left-hand window prior to scheduling them for 

submission. 
2. Send immediately by clicking Transmit Live. 

3. Schedule the submission to be sent at a later date by clicking Schedule this 
Submission. For more information on this subject, see Scheduling FBI Submissions. 

 

Transmit Live 
 

After clicking Transmit Live the Government Gateway Client screen will be displayed. Please 
check that the URL reads: 

 

 
 
Click Submit, Business Payroll will connect to the HMRC Government Gateway and transmit 

the end of year data. Please be aware that this process could take several minutes due to the 
large volumes of submissions made to the Government Gateway. 

 
When the submission has concluded, a message will be received stating “Message 

Successfully Sent”, in which case no further action is required. If a message is received 

saying “Submission received and awaiting processing”, then the submission status must be 
monitored – see Query Submission Status.  
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Sending a Multi Part FBI Submission 

 
Submitting P35 Part 

 
Select Submit to HMRC from the File by Internet menu. From the FBI Submission screen, 

confirm the authentication details, select the P35 Part and click OK. 

 
Business Payroll will check that all of the required information has been completed. If the 

company passes EOY Validation then the P35 Declaration screen will be displayed. 
 

P35 Declaration 

 
On the declarations screen enter the total number of P14 parts that will be submitted.  

 

 
 

Complete the Declarations, Checklist(1) and Checklist(2) sections of the P35 

Declarations screen, selecting any options that are applicable to the company. 
 

The Tax & NI, Statutory and Totals sections will display any information entered in the 
EOY Totals section. If required the figures can be entered or adjusted using these screens. 

 

Once completed, a submission can be previewed by clicking Build and Preview XML. The 
message can be sent immediately by clicking Transmit Live or schedule the submission for 

sending at a later time by clicking Schedule Submission. 
 

Transmit Live 
 

After clicking Transmit Live the Government Gateway Client screen will be displayed. Please 

check that the URL reads: 
 

 
 
Click Submit, Business Payroll will connect to the HMRC Government Gateway and transmit 

the end of year data. Please be aware that this process could take several minutes due to the 

large volumes of submissions made to the Government Gateway. 
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When the submission has concluded, a message will be received stating “Message 

Successfully Sent”, in which case no further action is required. If a message is received 
saying “Submission received and awaiting processing”, then the submission status must be 

monitored – see Query Submission Status.  
 

Submitting P14 Part 

 
Select Submit to HMRC from the File by Internet menu. 

 
The FBI Submission screen will be displayed, confirm the authentication details, select P14 

Part and click OK. 

 
On the FBI P14 Part screen, enter an ID for each the P14 submission in the Unique ID text 

box. A unique ID is required for each P14 part submitted. 
 

Click Transmit Live, and then on the Government Gateway screen click Submit. 
 

When the submission has concluded, a message will be received stating “Message 

Successfully Sent”, in which case no further action is required. If a message is received 
saying “Submission received and awaiting processing”, then the submission status must be 

monitored – see Query Submission Status.  
 

 

 
Scheduling FBI Submissions 

 

Adding a Submission for Scheduling  
 

After clicking Schedule Submission the Schedule FBI Submission screen will be displayed. 
The left-hand list on this screen shows the submissions which are available for scheduling. 

Select the item in the list using the left mouse button. 

 

 
 

Enter the required submission date / time in the Scheduled Date Time fields. 

 

Click the  button to schedule the submission. The right-hand column will now show 
the submission along with the date / time. 
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Change a Submission for Scheduling 

 
Select the submission in the right-hand list. The date / time details will be displayed in the 

fields at the bottom of the screen. 
 

Adjust these accordingly and click Update. 

 
If the scheduled submission needs to be removed, highlight the submission and click Delete. 

 
Stopping the Scheduler 

 

The submission scheduler can be stopped at any time by clicking Deactivate timer. 
 

 

 
Query Submission Status 

 
Due to the volume of submissions it is possible that the end of year data will be transmitted 

but not validated by the HMRC. In this situation Business Payroll will mark the submission as 

pending and it will be necessary to monitor the submission status by sending a query to the 
HMRC Government Gateway. 

 
Updating Submission Status 

 

The status of a pending submission can be 
checked at any time by selecting the Query 

Submission option from the File by Internet 
menu. 

 

 
 
When the FBI Query Status screen is displayed confirm that the authentication details are 

correct and select either Full & Complete or P38A, then click OK. 
 

Business Payroll will work through all of the submissions pending validation and update the 
status. 

 

Status Report 
To view the status of each company, 

select Status Report > EOY Status 
from the File by Internet menu to 

display the Selection Criteria for EOY 

Status screen. 
 

 
 

The companies that are to be reported on can be selected in this screen. Multiple companies 
can be selected by holding down the Ctrl key on the keyboard and click the left mouse 

button over the required companies. Once selected, click either Print or Print Preview to 
create the report. 
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efiling P45 Part 1 

 
Firstly, you will need to make the employee a leaver. To do this go Employee > Employee 

Maintenance from the menu at top. Select the Personal tab and enter Date Left. 
 

 
 

Once you have saved the changes 
to the Employee Maintenance, the 

window on the right will appear 

confirming your Sender ID and 
Password from the File By 

Internet ‘Setup’ screen. 
 

Select the Submit button to send 

or Schedule Submission to send 
at a time convenient to you. 

 
 

It will then validate the P45 which 
you select OK to confirm. 

 
 

You are given the option of 

viewing the XML file before 

sending. 
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Submitting the P45(1) to the HMRC 

 
If you have elected to Submit 

straight away, you will now be 
viewing the screen to right. To 

Schedule a Submission skip this 

step. 
 

The URL address is built within the 
software and will not need to be 

changed. 

 
You can view this file again before 

sending by selecting View XML, 
and it can be copied to folder. 

 
Select Submit to send your P45 to 

the HMRC. You will receive a 

confirmation email from the HMRC 
within 24 hours. 

 

 
 
If the below error appears during submission, incorrect details are held in one or more of the 

following - Tax District Number or Reference in Company Maintenance. Agent ID (if you’re 
registered as an agent), Sender ID or Password in the File by Internet > Setup screen. 

 

 
 
Scheduling a Submission 

 
From the menu at top, select File By Internet > Schedule Submission to view the below 

window. Highlight the P45 from the left window and enter a Scheduled Date and Time. 
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Select the arrows button. 

 

 

The selected P45 will now appear in the right window, as shown below. 
 

 
 

 

Now select the Activate Timer button. 
 

 
This will start the process of submitting the 
P45. 

 
You will receive a confirmation email from 

the HMRC within 24 hours. 

 
 
Note: Depending on your internet provider you may need to have an internet connection 

running before starting this process. 
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efiling P45 Part 3 

 
To efile a P45 Part 3 you must first enter the previous Pay and Tax details in the Employee 

Maintenance, as shown below. Select Save to enable the efile P45(3) button. 
 

 
 

The window on the right will 
appear confirming your Sender 

ID and Password from the File 
By Internet ‘Setup’ screen. 

 
Select the Submit button to send 

or Schedule Submission to send 

at a time convenient to you. 

 
 

It will then validate the P45 which 

you select OK to confirm. 

 
 

You are given the option of 

viewing the XML file before 
sending. 
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Submitting the P45(3) to the HMRC 

 
If you have elected to Submit 

straight away, you will now be 
viewing the screen to right. To 

Schedule a Submission skip this 

step. 
 

The URL address is built within the 
software and will not need to be 

changed. 

 
You can view this file again before 

sending by selecting View XML, 
and it can be copied to folder. 

 
Select Submit to send your P45 to 

the HMRC. 

 

 
 
If the below error appears during submission, incorrect details are held in one or more of the 

following - Tax District Number or Reference in Company Maintenance. Agent ID (if you’re 
registered as an agent), Sender ID or Password in the File by Internet > Setup screen. 

 

 
 
Scheduling a Submission 

 
From the menu at top, select File By Internet > Schedule Submission to view the below 

window. Highlight the P45 from the left window and enter a Scheduled Date and Time. 

 

 
Select the arrows button. 
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The selected P45 will now appear in the right window, as shown below. 
 

 
 

 

Now select the Activate Timer button. 
 

 
This will start the process of submitting the 
P45. 

 
You will receive a confirmation email from 

the HMRC within 24 hours. 

 
 
Note: Depending on your internet provider you may need to have an internet connection 

running before starting this process. 
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efiling P46 

 
To efile a P46 select the efile P46 button in the Employee Maintenance 

 

 
 

 
The window on the right will 

appear confirming your Sender 

ID and Password from the File 
By Internet ‘Setup’ screen. 

 
Select either the Submit or 

Schedule Submission button to 

trigger the P46 Declaration 
screen. 

 
 

On the P46 Declaration you’ll 

have various options that will 
reflect this employee. 

 

Select the Submit button to send 
or Schedule Submission to send 

at a time convenient to you. 
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You are given the option of 

viewing the XML file before 
sending. 

 
 

 

Submitting the P46 to the HMRC 
 

If you have elected to Submit 
straight away, you will now be 

viewing the screen to right. To 
Schedule a Submission skip this 

step. 

 
The URL address is built within the 

software and will not need to be 
changed. 

 

You can view this file again before 
sending by selecting View XML, 

and it can be copied to folder. 
 

Select Submit to send your P46 to 
the HMRC. 

 

 
 

If the below error appears during submission, incorrect details are held in one or more of the 
following - Tax District Number or Reference in Company Maintenance. Agent ID (if you’re 

registered as an agent), Sender ID or Password in the File by Internet > Setup screen. 
 

 
 

 
Scheduling a Submission 

 
From the menu at top, select File By Internet > Schedule Submission to view the below 

window. Highlight the P46 from the left window and enter a Scheduled Date and Time. 
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Select the arrows button. 

 

 

The selected P46 will now appear in the right window, as shown below. 

 

 
 

 
Now select the Activate Timer button. 
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This will start the process of submitting the 

P46. 
 

You will receive a confirmation email from 
the HMRC within 24 hours. 

 
 

Note: Depending on your internet provider you may need to have an internet connection 
running before starting this process. 

 
 

 
CIS Monthly Submission 

 
A monthly submission for Subcontractors must be submitted to the HMRC every month. 

Failure to do so will result in penalties from the HMRC. 

 
 

To submit a subcontractors 
salary, select File By 

Internet from the top menu, 

then Submit to HRMC. 

 
 
The screen to right will 

appear. 
 

Select Monthly Return, and 

then OK. 
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Once OK selected the below screen opens showing subcontractors amounts. 

 

 
 
 

Before any transaction takes 

place, please confirm the 
check-list on the Declarations 

screen. 

 
 
Select Print to copy this file. 
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Press Transmit Live to submit 

now… 

 

 
 

…or Schedule this 
Submission to send at a time 

convenient to you. 

 

 

 
Both of the above actions use the same process when efiling P45, P46, End Of Year or CIS 

Verification, in this manual/help. 
 

 
System Administration 

 

There are a variety of different system options 
available from the Admin menu. 

 
Registration is covered at the start of this 

manual. 
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System Options 

 
 

Miscellaneous  
The Restore options will remember the employee, company and the size of the screen last 

used. These are used when the program is reloaded. 

 
The Disable Archive will stop the prompt to backup the database when the program quits.  

Even if the prompt has been disabled and a standalone version is being run on the PC an 
archive prompt will appear once a month and an archive must be saved. 

 
Reports 

To make the report preview window open its maximized state, tick the Show Reports 

Maximized check box. 
 

In some cases it is necessary to delay the time taken to send the report to the printer.  The 
Report Print Time Delay allows for a pause time in 1 second increments. 

 

Report Zoom% allows you to set the default zoom level for the report preview window.  
 

 

 
User Management 

User Management allows new users to be set up and with varied permissions which can be 
adjusted for each company.  These options are only applicable on multi user systems and are 

only accessible to the supervisor. 
 

User Tree View 

 

The primary role of the tree view is for the 

selection of users to be edited.  To do this, 

click the left mouse button over the required 
user to highlight them.  Any options set will 

be shown.    
 

From the Tree View the various states of the 

users can be viewed.  Click the +/- sign next 
to the folders to expand/collapse the lists. 

 

Company Selection 

 

Users can have different attributes for 
individual companies. 

 
Select the users in the tree view, then select 

each company in turn, adjusting the attributes 
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as required. 

 
 

User Permissions 

  
 

 

These options relate to employee and 

company functions. 

  
To give the user permission to perform a 

function, place a tick in the relevant box. 
As mentioned previously, these options can 

be set individually for each company.  To 

make the selected options applicable for all 
companies tick the Apply to All Companies 

check box.  This can then be overridden if 
necessary.   

 
User Status 

 

It is possible to lock a user’s account to stop 

unauthorized logging on. 
 

It is also possible to give or remove 
supervisor rights.  Please note there must 

always be at least one supervisor account.  

 
Username And Password 

 

 

Change the username and password here.  
This is only accessible by the supervisor.  

Users can change their own password 
through Admin > Change Password. 

 

Other Functions  
It is possible to print all of the users and their attributes by clicking the Print button. 

All users can be stopped from logging into the system by clicking the Lock Out All button.  
Clicking the button a second time will reactivate all users. 

 

 

 
Default User Management Settings 

Shown below are the default user settings. When creating a new user, the user will be 
activated with whatever privileges are set here.  
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Default Company 

Default Company allows the user to set defaults on the General, Calendar, Reports and GL 
Codes tabs on the Company Maintenance screen. Each time a new company is added the 

Company Maintenance screen is opened with the saved defaults. 

 

 
 

 

 
Change Password 

To change the password of the user that is currently logged on as: 
 

 

• Enter the Current password. 

• Enter the New password. 

• Enter the new password again in the 

Confirm Password field. 

• Click Save to complete the operation. 

 
At anytime click Cancel to quit without saving. 

 

 

 
Payroll Status Report 

This report gives the status of any open or closed pay periods and is broken down by pay 
frequency.  The report is viewed and printed like any other report.  For more detail on reports 

see the Reports section earlier in this manual. 
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Post Budget Tax Code Uplift 

Each year certain tax codes require uplifting as per the budget. Business Payroll has a 

function that will raise tax codes.  This function must only be run once per company on the 

specific date, and will affect all active, applicable employees within the selected companies. 
 

 
Which Codes will be affected 

 

Example: 

 

The Uplift screen will show the code suffix 
and the uplift for the code. 

 

 
Selecting the Companies to Uplift 

 

 
 

All companies will start in the Company List on the left of the screen. 

 
• Highlight the required company by clicking the left mouse button over the company 

name. 

• Click the Add button. 

• The company will move to the Selected Companies area on the right of the screen. 

• To remove a selected company, select the company in the right window and click 

Remove. 
• Click Update to complete the operation. 

 

Once completed, the updated companies will be removed from the list and therefore cannot 
be updated again. 
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Archive and Restore Data 

Archive and Restore data allows payroll data to be backed up to either a hard disk drive or 

removable media. N.B If the backup is intended to be saved on a CD-ROM, the archive must 

be saved to the hard disk drive first and then burnt onto the CD. 
 

 Archive and Restore Utility 
 

 

 

 

 

Archiving Payroll Data 

 
• Click the Archive button to open the file dialog window. 

• Select the location to save the backup. 

• The File Name consists of Year-Date-Time, example Q2002-08-14@142051.arc. The 

file name can be changed. 

• Click Save to start the backup. 

 

A counter will show the progress of the 
backup.  When complete click Ok on the 

message box and then Close.  
 

 
 

 

 
Archiving to Floppy Disk 

 
 

If the file has been requested to save to floppy 

disk, then a message will be displayed 
prompting a disk to be inserted. Once the disk is 

in the drive click Ok. 
 

 
 

 

If the backup is too large to fit on one disc, a 
message will be displayed prompting for a 

second disk to be inserted. Click Ok when the 
second disk is in the drive. 

 

 

 

Restoring Payroll Data 

 

Click the Restore button and a 

file window will appear. 
Select the data file to restore. 

Click Open. 

A warning message will be 
displayed, (opposite). 

Click Yes to All to complete 
the restore. 
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Personnel Manager 

DIAMOND DISCOVERY Business Payroll can import data from Vizual’s Personnel Manager 

program.  To do this, go to Admin > Personnel Manager > Link Status. 

 

 

To turn on the link, click the 

Activate Link check box. 
 

Choose the location of the 

interface files. 
 

Click Save. 
 

Click Cancel at any time to 
quit without saving. 

 

Clear Link History File 

All interface records between DIAMOND DISCOVERY Business Payroll and Personnel Manager 
are logged.  To permanently remove these records from this log file enter a date and click 

Clear. 
 

Import Lock Status 
This field shows the current status of the link.  If the software is importing data it will change 

to Active. In the event of a crash, clicking the Clear button will reset the import operation. 

 
Also available from the Personnel Manager menu are options to: 

 
Refresh Data 

This option will start the import process. 

 
Export All Data 

This option will export all data to the location specified in the Personnel Manager Link screen.  
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Company Export 

There may be occasions when a selection of companies needs to be exported. DIAMOND 
DISCOVERY Business Payroll allows this with the use of the Company CSV Export and 

Company MDB Export functions. These functions can be found by selecting Admin -> Data 

Conversion from the main menu. 
 

Company MDB Export… 
 

 

Upon opening the Company MDB 

Export window, a list of companies 
will auto-populate in the Companies 

list area.  
 

Select the companies that are to be 

exported and from the Export 
Location window, select a destination 

for the exported file. 
 

Click the Export button to begin 
exporting the chosen companies. 

 

 
Company CSV Export… 

 

The Company CSV Export function exports all company data in the form of a number of CSV 
files. These CSV files are organized in their own folder, the folder being exported to a chosen 

location. 
 

 

Upon selecting the Company CSV 

Export option, a window will be 
displayed with the intended location 

of the exported file. 
 

To change the file location, click the 

‘…’ button. 
 

Once the location has been selected 
click Export. 

 

 

 
Compact and Repair 

Running the 'Compact and Repair' utility regularly will help keep the database at a 
manageable size. 

 
This utility can only be used if no users are connected to the database. Therefore, it is 

recommended that this utility be used at a time when no user, other than the supervisor, is 

on the system. Note that no harm will come to the database if the utility is launched while 
another user is connected; the utility will simply report that the database could not be 

compacted. If this occurs, ensure that all other users are logged out and try again. 
 

The Compact and Repair utility that comes with Business Payroll can be accessed through 

Admin -> Compact and Repair from the main menu options. The database will then be 
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compacted. The program will display a notification once the process is complete. 

 

  
Importing Company Details 
DIAMOND DISCOVERY Business Payroll has a ‘Company Import’ function that allows external 

company information to be imported at any point during the tax year. The information to be 

imported is in the form of ‘comma separated’ files (.CSV), these files being arranged in a 
specific format. Please find examples of the format of the import files on the DIAMOND 

DISCOVERY Installation CD. 
 

There are 9 files in total per company. These are as follows:- 
 

Company.csv 

Employee.csv 
EmployeeBF.csv 

EmployeeBFNI.csv 
AdditionDeduction.csv 

EmployeeAdditiondeduction.csv 

Pension.csv 
EmployeePension.csv 

EmployeeAEO.csv 
 

 
Each company and its related .CSV files should be stored in a separate directory named after 

the company, as outlined below. 

 
Drive:\ 

 
                Test Company A 

   

 
   Company.csv 

   Employee.csv 
   EmployeeBF.csv 

EmployeeBFNI.csv 

AdditionDeduction.csv 
EmployeeAdditiondeduction.csv 

Pension.csv 
EmployeePension.csv 

EmployeeAEO.csv 
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Once the CSV files have been 

prepared, the company details 
can be imported. Select 

Admin -> Data Conversion 
-> Company Import from 

the main menu.  

 

 
 
 

From the Data Migration window (below), select the source and target folders by clicking 

Browse and selecting the appropriate directories – N.B the source folder must contain a 
folder for every company.  

 

 
 

Click Prepare to display a list of relevant files in this directory. Highlight the file that is to be 
imported and click Import. All information in this file will be imported into Business Payroll. 

The program will need to be restarted to refresh company information. 
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Appendix. 

 
Company.csv 

 

COMPANY.CSV (This file contains all the company specific details) 

        

        

Field 
Number Name Type Description / Value(s) 

        

1 CompanyName Text Company Name 

2 Address1 Text Company Address Line 1 

3 Address2 Text Company Address Line 2 

4 Address3 Text Company Address Line 3 

5 Address4 Text Company Address Line 4 

6 Postcode Text Company Post Code 

7 Country Text Company Country 

8 PhoneNumber Text Company Phone Number 

9 TaxDistrict Text Tax District 

10 TaxRef Text Tax Reference 

11 TaxDistName Long Tax District Name 

12 lngNICMethod Long 
Default NIC Calculation method for the Company.  
Values: 0: Exact; 1: Table 

13 lngCalculationType Text 
Default Calculation Type for Company.  
Values:  0: Gross to Net; 1: Net to Gross 

14 BankName Text Company Bank Name 

15 BankSortCode Text Company Bank Sort Code 

16 BankBranch Text Company Bank Branch 

17 BankAccountNo Text Company Bank Account Number 

18 BankAccountName Text Company Bank Account Name 

19 BSocRollNo Text Building Society Roll Number 

20 BOBSAutopayNo Text Autopay/BOBS/Faxpay/Telepay Number 

21 PayFrequency Text 

Default Pay Frequency for Company. 
Values: M = Monthly; W = Weekly; 2 = 2 Weekly; 4 = 4 
Weekly; Q = Quarterly; H = Half Yearly, A = Annual  
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AdditionDeduction.csv 
 
AdditionDeduction.CSV (This file contains Additions and deductions set up for each individual 
company.) 

        

        
Field 
Number Name Type Description / Value(s)  

        

1 PKAdditionDeduduction 
Long 
Integer 

Primary Key to uniquely identify the 
Addition/Deduction 

2 Description Text Eg "Basic Pay", "Employee Pension" etc. 

3 ShortDesc Text Short code for description 

4 Addition Yes/No Yes = Addition; No = Deduction. 

5 Tax Yes/No 

Addition: Yes = addition is subject to tax; No = 
addition is not subject to tax.  Deduction: Yes = 
deduction is allowable for tax, No = deduction is not 
allowable for tax. 

6 NIC Yes/No 

Addition: Yes = addition is subject to NI; No = 
addition is not subject to NI.  Deduction: Yes = 
deduction is allowable for NI, No = deduction is 
subject to NI. 

7 Pension Yes/No 

Yes = addition/deduction included in calculation of 
pension payment; No =  addition/deduction not 
included in calculation of pension payment 

8 Holiday Yes/No 
Yes = Additional Holiday Payments; No = no 
Additional Holiday Payments. 

9 GrossUp Yes/No 
Yes = Addition is grossed up; No = Addition is not 
grossed up. 

10 Multiplier Double 
Applied to the basic hourly rate, or to the Optional 
Rate in this record if it's non-zero. 

11 OptionalRate Double 
Optional rate. If a value is entered here then it is 
used instead of the basic hourly rate. 

12 ReducingBalance Yes/No   

13 CarryForwardDeficit Yes/No   

14 PayslipPriority 
Long 
Integer 

Order in which additions/deductions will be printed 
on the payslip. 

15 BACSDeduction Yes/No a deduction to an additional Bank Account by BACS 

16 blnHolidayCredits Yes/No 

Yes = Include in Holiday Credits Accrued Gross Pay 
calculation; No = not included in Holiday Credits 
Accrued Gross Pay calculation 

17 blnHolidayPay Yes/No 
Yes = Holiday Pay addition; no = not a holiday pay 
addition 
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Pension.csv 
 
Pension.CSV (This file contains Company Pensions) 
  

        

        

Field Number Name Type Description / Value(s)  

        

1 PKPensionFund Long Integer 
Primary Key to uniquely identify the 
Pension 

2 strPensionFundName Text Pension Fund Name Description 

3 strSchemeRef Text Pension Scheme Reference 

4 strSCONCOMP Text 
Company Pension SCONCOMP 
Number 

5 strSCONCOMPSuffix Text 
Suffix for Company Pension 
SCONCOMP Number 

6 lngSCONCOMPSchemeType Long Integer SCONCOMP Scheme Type 

7 strSCONCOSR Text Company Pension SCONCOSR 

8 strSCONCOSRSuffix Text 
Suffix for Company Pension 
SCONCOSR Number 

9 lngSCONCOSRSchemeType Long Integer SCONCOSR Scheme Type 

10 blnIRAPP Yes/No 
Inland Revenue Approved Pension 
Plan 

11 lngECONSCONSelection Long Integer None = 0;COMP=1;COSR =2; 

12 blnGrossLessBasicRateTax Yes/No 
Requires Pensionable Pay to be 
Gross Less Basic Rate Tax 

13 blnHoliday Yes/No 

Yes = Additional Holiday Payments; 
No = no Additional Holiday 
Payments. 
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Employee.csv 
 

EMPLOYEE.CSV (This file contains all employee details) 

        

        
Field 
Number Name Type Description / Value(s)  

1 StaffNo Text Staff Number 

2 Title Text 
Mr, Mrs, Miss, Ms, Dr, Prof, Sir, Rev, Lord, Lady, 
Earl, Duke, Duchess, Prince, Princess, Rt. Hon. 

3 Surname Text Employee's Surname 

4 Forenames Text Employee's Forname(s) 

5 Salutation Text 
Salutation - eg "Albert" or "Mr Hall", suitable for 
the salutation in a letter (prefixed by "Dear "). 

6 Gender Text M=Male; F=Female 

7 EmailAddress Text Employee's email address 

8 Address1 Text Employee's Address Line 1 

9 Address2 Text Employee's Address Line 2 

10 Address3 Text Employee's Address Line 3 

11 Address4 Text Employee's Address Line 4 

12 Postcode Text Employee's Post Code 

13 PhoneNumber Text Employee's Phone Number 

14 MaritalStatus Text 0=Single, 1=Married,  2=Widowed, 3=Divorced. 

15 DOB Date/Time Date of Birth 

16 JoinDate Date/Time Date of joining company 

17 LeaveDate Date/Time Date of leaving company 

18 Director Yes/No Yes =  is a director;  No = is not a director. 

19 DirectorDate Date/Time 

Date from which NI is calculated on Director's 
basis (if no date then whole tax year on Director's 
basis). 

20 CurTaxCode Text Current Tax Code e.g. 461L 

21 CumulativeTaxBasis Yes/No 
Yes = tax calculated on a cumulative basis; No = 
tax calculated on a week1/month 1 basis. 

22 CalculationType 
Long 
Integer 0: Gross to Net; 1: Net to Gross 

23 NINumber Text National Insurance Number 

24 NICode Text A,B,C,c,D,E,F,G,J,L,S,X 

25 PayRate Double Hourly Pay rate 

26 Salaried Yes/No 
Yes = paid on salary basis; No = paid on hourly 
basis. 

27 Salary Double 

Salary per annum for monthly, quarterly, half 
yearly and annually paid staff. Salary per week for 
weekly, 2 weekly and 4 weekly paid staff 

28 PayDate Date/Time date that pay rate is effective from. 

29 StdHours Double 
Hours per month (for monthly paid) or per week 
(all other frequencies). 

30 CurTaxPeriodWM 
Long 
Integer Current tax period Week/Month 

31 HolidayHours Yes/No 
Yes = Holiday allowance is expressed in hours; 
No = Holiday allowance is expressed in days. 

32 HolsAllowance Double 
Days (or hours) of holiday allowance. Can be half 
days (or hours). 

33 HolsTaken Double Number of days (or hours) holiday taken. 

34 P45GP Double 
Gross Pay Amount on the P45 when employee 
joined company. 

35 P45Tax Double 
Tax Amount on the P45 when employee joined 
company. 

36 IRPRNumber Text Inland Revenue Personal Reference Number 
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37 BankName Text Employee's Bank Name 

38 BankSortCode Text Employee's Bank Sort Code 

39 BankBranch Text Employee's Bank Name 

40 BankAccountNo Text Employee's Bank Account Number 

41 BankAccountName Text Employee's Bank Account Name 

42 BSocRollNo Text Employee's Building Society Roll No. 

43 BOBSAutopayNo Text Autopay/BOBS/Faxpay/Telepay Number 

44 DepartmentName Text Department Name 

45 PayrollStatus Text 
A = Active; L = Leaver; O = On-hold; T = Trade 
Dispute 

46 PaymentMethod Text 

1=Cash; 2=Cheque; 3=Giro; 4=BOBS; 
5=Autopay; 6=BACS; 7=Faxpay; 8=Telepay; 
9=Pay Flow; 10=N/A 

47 PayFrequency Text 

M = Monthly; W = Weekly; 2 = 2 Weekly; 4 = 4 
Weekly; Q = Quarterly; H = Half Yearly, A = 
Annual 
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EmployeeBF.csv 
 

EmployeeBF.CSV (This file contains brought forward year to date figures for each employee.) 

        

        
Field 
Number Name Type Description / Value(s)  

        

1 StaffNo Text Staff Number 

2 TaxWM 
Long 
Integer B/F tax week/month number. 

3 GP Double B/F Amount paid to the employee this tax year. 

4 Tax Double 
B/F Amount taken in tax from the employee this tax 
year. 

5 NetPay Double B/F Net Pay  

6 Round Double B/F Amount now owed to the employee. 

7 SSP Double B/F SSP Amount paid to the employee this tax year. 

8 SMP Double B/F SMP Amount paid to the employee this tax year. 

9 SMPReclaim Double 
B/F SMP Reclaim Amount claimed back from the 
Revenue this tax year. 

10 SAP Double B/F SAP Amount paid to the employee this tax year. 

11 SAPReclaim Double 
B/F SAP Reclaim Amount claimed back from the 
Revenue this tax year. 

12 SPP Double B/F SPP Amount paid to the employee this tax year. 

13 SPPReclaim Double 
B/F SPP Reclaim Amount claimed back from the 
Revenue this tax year. 

14 SLoan Double 
B/F Student Loan Amount taken from the employee 
this tax year. 

15 WFTC Double 
B/F Tax Credit Amount paid to the employee this tax 
year. 
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EmployeeBFNI.csv 
 
EmployeeBFNI.CSV (This file contains brought forward NI year to date figures for each 
employee.) 

Note: Where an employee has had an NI code change within the current tax year there should 
be a separate record for each NI Code. 

        

Field 
Number Name Type Description / Value(s)  

        

1 StaffNo Text Staff Number 

2 NICode Text NI Code 

3 NIGross Double 
B/F Gross NI-able pay  this tax year for the 
indicated NI Code. 

4 NIEe Double 
B/F Gross E'ee NI this tax year for the indicated 
NI Code. 

5 NIEr Double 
B/F Gross E'er NI this tax year for the indicated 
NI Code. 

6 NITotal Double B/F Total NI for this tax year (dblNIEe + dblNIEr) 

7 NIEeRebate Double 
B/F Gross E'ee NI Rebate this tax year for the 
indicated NI Code. 

8 NIErRebate Double 
B/F Gross E'er NI Rebate this tax year for the 
indicated NI Code. 

9 NIEarnings Double 

B/F Earnings (equivalent to "Up to LEL", "LEL to 
E'ee Threshold" etc added up) for the indicated 
NI Code (n/a for 2001-2002). 

10 UpToLELEarnings Double 
B/F Earnings up to the LEL this tax year for the 
indicated NI Code. 

11 LELToETEarnings Double 
B/F Earnings from the LEL up to the Earnings 
Threshold this tax year for the indicated NI Code. 

12 ETToUELEarnings Double 
B/F Earnings from the Earnings Threshold up to 
the UEL this tax year for the indicated NI Code. 

13 AboveUEL Double B/F Earnings above UEL 

14 NICodeOrder 
Long 
Integer 

Order in which NI Codes changed throughout the 
tax year 
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EmployeeAdditionDeduction.csv 
 
EmployeeAdditionDeduction.CSV (This file contains Additions and deductions set up for an 
employee) 

        

        
Field 
Number Name Type Description / Value(s)  

        

1 FKAdditionDeduction 
Long 
Integer Link to Addition/Deduction 

2 StaffNo Text Staff Number 

3 PaymentMethod 
Long 
Integer 

1=Cash; 2=Cheque; 3=Giro; 4=BOBS; 
5=Autopay; 6=BACS; 7=Faxpay; 8=Telepay; 
9=Pay Flow; 10=N/A 

4 Hours Yes/No 
Yes: Hours (applies only to additions); No: 
Amount of Addition/Deduction. 

5 Value Double 
Number of hours or the amount of 
addition/deduction. 

6 LoanAmount Double Original amount (Deductions only) 

7 BFLoanAmount Double 
Current outstanding balance  (Deductions 
only) 

8 LoanDeduction Double 
Amount deducted each period  (Deductions 
only) 

9 BFLoanDeduction Double Amount already deducted  (Deductions only) 

10 RBStartDate Date/Time 
Date of first deduction to be taken.  
(Deductions only) 
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EmployeePension.csv 
 
EmployeePension.CSV (This file contains Employee Pension Details) 
  

        

        
Field 
Number Name Type Description / Value(s)  

        

        

1 StaffNo Text Staff Number 

2 lngFKPensionFund 
Long 
Integer Link to pension fund 

3 PensionSchemeType Text Values: A,B,C,D,E,F,G,H,I 

4 strEmployeeSchemeRef Text Pension reference. 

5 dblMPEE Double 

Employee pension value. (Note the field 
name is misleading - it can apply to 
either the Main Pension or and Additional 
Pension contributions) 

6 dblMPER Double 

Employer pension value. (Note the field 
name is misleading - it can apply to 
either the Main Pension or and Additional 
Pension contributions) 

7 blnMainPension Yes/No 
Yes = Main Pension; No = Additional 
Pension. 

8 blnEmployeePercentage Yes/No 

Yes: Employee pension value is 
calculated as a percentage of 
pensionable pay; No: Employee pension 
is a fixed amount 

9 blnEmployerPercentage Yes/No 

Yes: Employer pension value is 
calculated as a percentage of 
pensionable pay; No: Employer pension 
is a fixed amount 

10 dblEePercent Double 
Employee percentage of pensionable 
pay 

11 dblErPercent Double Employer percentage of pensionable pay 

12 blnLimits Yes/No 
Yes = Pension Limits; No = No Pension 
Limits. 

13 blnEmployerPaysEeNIRebate Yes/No 

Yes =  Employer pays employee NI 
rebate; No = Employer does not pay 
employee NI rebate. 

  
 
 
 
 
 
 
      

  

Note: The following are 
descriptions of the different 
pension scheme types.     
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A - (COSR) C/out Salary Related 
B - (CISR) NOT C/out Salary Related 
C - (COMP) NI Rebate value only 
D - (COMP) NI Rebate + additional contributions 
E - (COMP) NI Rebate OR additional contributions 
F - (AVC) Additional Voluntary Contributions 
G - (FSAVC) Free Standing AVC 
H - (PPP) Personal Pension Plan 
I - (SHP) Stake Holder Pension  
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EmployeeAEO.csv 

 
EmployeeAEO.CSV (This file contains Employee AEO Details) 
  

        

        

Field 
Number Name Type Description / Value(s)  

        

        

1 StaffNo Long Integer Staff Number 

2 AEOType Long Integer 

Values: PAEO, CPAEO, NPAEO, 
CNPAEO, AE on AOS, CCAEO, 
CTAEO, DEO, SEA, SCMA, SCAO 

3 LoanAmount Double Original amount 

4 BFLoanAmount Double Current o/s balance 

5 LoanDeduction Double Amount deducted each period 

6 BFLoanDeduction Double Amount already deducted 

7 RBStartDate Date/Time Date of first deduction to be taken. 

8 AEOReferenceNumber Text AEO Reference Number 

9 AEODateOfIssue Date/Time Date AEO issued 

10 AEODateReceived Date/Time Date AEO Received 

11 FinishDate Date/Time Date deductions finish 

12 AOEIssuingBodyReference Text AEO Issuing Body Reference 

13 AEOApplyAdminCharge Yes/No 
Yes: Apply Admin Charge; No: Do not 
apply admin charge 

14 ProtectedEarnings Double Protected earnings 

15 PaymentsFinished Yes/No Finished deductions 

16 CAOEARequired Yes/No 
Is an Earning Arrestment required on 
this Conjoined Arrestment Order 

        

      
Note: The following are descriptions of 
the Different AEO Types 

      PAEO -Priority AEO 

      CPAEO - Consolidated Priority AEO 

      NPAEO - Non-Priority AEO 

      
CNPAEO - Consolidated non-priority 
AEO 

      
AE on AOS - Attachment of Earnings on 
an Admin Order 

      CCAEO - Community Charge AEO 

      CTAEO - Council Tax AEO 

      
DEO - Child Support Deduction from 
Earnings order 

      
SEA - Scottish Earnings Arrestment 
Order 

      
SCMA - Scottish Current Maintenance 
Arrestment Order 

      
SCAO - Scottish Conjoined Arrestment 
Order 
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Help Menu 
The Help options can be accessed from the 

help menu.  

 
 
 

 
Tax Periods 

To examine where a specific date falls in a tax week or tax month, use the Tax Periods 

calendar. 
 

 

 
Select a date using the dropdown lists to 

choose the tax month and year. 

 
Click the left mouse button over one of the 

days. 
 

The tax week and tax month are displayed in 

the fields at the bottom. 

 
 

 
Rates 

By calling up the Rates option all the NI, SSP, SMP and Tax rates for the current year will be 

displayed. 
 

 

 
Use the tabs at the top to select the 

rate to view. 
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Help Topics 

The Help Topics option will load the on-line manual. This can be accessed at any time within 

Business Payroll by pressing the F1 key on the keyboard.   

 

  
About 

The About option shows information about the software.  

 

 

 
 

 
 

 
 

 
 
         Version Number 

 

 
By clicking on the System Info button another screen will be displayed showing the version 

number of the calculation file.  
 

 

 
 

 

 
 Version Number 

 

 
 

 
 

 

 
These two version numbers are useful when contacting support at Diamond Discovery 

Solutions. 
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Company Maintenance - Commercial 

 
Business Commercial contains functions for parallel running with another payroll system and 

extended functionality for General Ledger Coding. 

   
Select Company Maintenance from the 

Company menu. 
 

 

 

 
Bureau 

Parallel Run Indicator 
 

By default all new companies set up on Business Commercial will be in Parallel Run Mode and 
is indicated by the background colour of the company drop down box. 

 

   
 
Orange Indicates Parallel mode and white Live mode. 

 

Include Open Employees in BACS Report  
 

By Default the BACS report will not included any employees who are in an open state.  If all 
employees are required to be included then check this box.  

 

Re-open Periods 
 

The Re-open period function will open the latest closed period for the company.  
 

To Re-open all employees for the selected pay frequency:  
 

• Tick the checkbox next to the required pay frequency.  The Tax Period field next to 

the selected frequency will contain the period number that will be Re-opened. 

• Click Re-open. 

 
Set Employee B/F figures 

 
Set Employee B/F (Brought Forwards) is used to make adjustments to figures calculated with 

Business Commercial while parallel running alongside another payroll system. 

   
The principal behind this is that the previous individual pay records are combined into a single 

brought forward record.  Theses brought forward figures can then be accessed and amended 
through the Employee Brought Forward screen. 

 

• Click the Set Employee B/F Figures button and when the process has finished, 
close the Company Maintenance screen. 

• Select Employee Brought Forward from the Employee menu. 

• Select the employee using the Select Employee combo box. 

• Click the Unlock button, then click Yes to the warning message. 

 

The brought forward details can now be adjusted to reflect the results of the other system.   
 

Go Live  
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The Go Live button takes the company from Parallel Run mode to Live mode.  The Live 

mode disables the ability to set the Employees brought forward details. 

 
GL Codes 

 
The GL Code section on the Company Maintenance screen gives you the facility to 

organise the GL Export report according to the company’s structure. 
 

Element is the lowest level e.g. the individual parts such as Total Gross Pay or each 

Deductions etc. By default this is included and is set to the maximum size of 16. 
 

Before adding additional categories, the maximum character length for Element must be 
reduced from 16 to the actual character length used by the company.  This is because 16 

characters is the maximum length available for all categories used. E.g. company and 

department can both have a character length of 5, leaving a maximum character length of 6 
for the Element category. 

 

 
 
 

Adding Categories 
 

Initially, reduce the maximum character length for the element category.  Left click on the 

Element in the right hand window and enter the required character length in the Length 
field. 

 
To select additional categories, left click the required category in the left-hand window.  Then 

click the  button to move it to the selected categories list (right-hand window). When the 
category has been selected set the character length. If Company is selected as a category 

then a GL Code for the company must be entered in the GL Code for Company Field. 

To move all categories, click the  button. 

 

 
 

 
Ordering the Categories 

 

Select the category in the right-hand window and then use the  or  buttons to move 

the category up or down in the list. 



 113 

 

GL Report 
 

The GL Export report 
can be found under the 

Reports > Company 

> GL Export menu 
option. 

 
 

  

 
Departmental Costing 

Departmental Costing allows a portion of the employee’s gross pay to be attributed to 
different departments within the company.  

 

To enable Departmental Costing departments must be set up in advance. For more 
information on setting up departments please see Divisions/Departments/Locations, 
G/L Codes. 
 

Applying costing to the employee 

  
Highlight the employee in the list and select 

Employee Maintenance from the Employee 
dropdown menu  

  

 

On the General tab of the Employee 
Maintenance screen use the dropdown list 

to select the required department.  Then 

enter the percentage to be attributed to 
that cost centre.  The cost can be spread 

over a maximum of five departments. 

 

Departmental Costing Reports 
 

The costing reports can be found under Pro Reports under the Reports menu and are as 

follows. 
 

Department Costing Summary: The percentage allocated to each department, for each 
employee. 

 

Department Costing Totals: Payment and deduction totals broken down by department. 
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Employee Cost Report: Employees individual costs grouped by department. 

 
 

 
Holiday Credits 

Default Holiday Credits settings   

 

New employees can have holiday credits applied to their records automatically by creating 
defaults in the Company Maintenance screen. 

 
Select Company Maintenance from the 

Company menu. 

 
  

 

In the General section, enter the percentage of 
Gross Pay to be accrued for holiday credits.  A 

threshold for which holiday credits will be 
calculated up to can be set by entering a value in 

the Gross Pay Limit field. 

 
 

 

A warning message will be displayed when the employee is approaching the anniversary of 

their start date.  In some situations this is not desirable and therefore can be disabled by 
ticking the Disable Holiday Credits Anniversary checkbox. 

 

To include any statutory payments such as sick pay or maternity pay in the holiday credits 
calculation, tick the Include Statutory Payments checkbox.   
 

Individual Employee Settings 

 
The holiday credit percentage applied to individual employees can be viewed or amended by 

opening Employee Maintenance and selecting the Personal tab. 

 

 

The Percentage of Gross Pay used in the holiday 

credit calculation is the only editable field.  
Should an adjustment to the holiday credit total 

be necessary, see Paying Holiday Credits 
below. 
 

 
 

Paying Holiday Credits 

 
• Open & Pay the employee and click the Change button. 

• Select Absence Recording tab. 

• Click Add New Absence. 
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Choose Holiday from the Absence 

Type drop down box. 
 

Enter the start and end dates of the 
holiday. 

 

Enter the amount of credits to be taken. 

Click Save and then Close. 
 

The Holiday Credit amount will be 

displayed in the Additions field on the 
main calculation screen. 

 
Please note that positive or negative adjustments to the holiday credits balance can be made 

using the Holiday Credits Adjustment this Period field. 
 

Holiday Credits Reporting 

 
The Holiday Credits reports can be found under Pro Reports on the Reports menu and are 

as follows. 
 

Detailed Holiday Credits:  This report shows a complete breakdown for each employee period 

by period. 
Holiday Credits: Holiday gross pay percentage, holiday taken and Holiday credits remaining 

by employee. 
 

 

 
Bureau Details 

 
To access the Bureau Details option, select 

Company then Bureau Details from the 
main screen. 

 

These details will then be used in the BACS 
authorisation report. 
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Company Sections 

 
Company Sections allow a group of selected companies to be worked on independently from 

other groups of companies. This can be advantageous when paying weekly or monthly 

companies with nil addition/deductions etc. 
 

 

 
Section Maintenance 

 

To access the Section Maintenance 
option, select Company > Company 

Sections > Section Maintenance from 
the main menu. 

 
 

 
  

 

 
Enter the Section name and Description in the 

lower fields. 
 

Select Save. 
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Company sections 

Adding a Company to a Section 
 

Select Company -> Company Sections -> CompanySections to access the screen 

below. 
 

Any companies that do not belong to a section will be displayed in the list on the left of the 
Company Section screen. 

 

 
 

 
Select a previously saved section from the 
drop-down list. 

 

Press Add to place under the section on the 

left. 
There is also a Remove button to reverse 

the action. 

 

Select Save. 

 

 
 

Below is a list of further options in Company Sections. 
 

 
Up to 0ne hundred companies can be 
viewed.  

 

 

Select All, Deselect All and Inverse 
Selection to make adding more efficient. 
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Current Section 

The Current Section option allows the user to view and work on one section at a time - select 
Company > Company Sections > Current Section from the main menu. 

 

 

From the Section menu, select the 
section required. 

 
Click Save to view this section.  

 

 
 

 
Pay Selected Companies 

Sections of companies can be paid in one action. To view the below screen, select Company 
and Pay Selected Companies. 

 

 
 
 

Highlight the company or companies to be paid or closed. Confirm the Pay Period, Frequency 
and Action before selecting Pay All. 
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Creating Import Files 
The Create Import File function creates a .csv (comma separated value) file, which can be 

edited in a spreadsheet package. The created import file automatically contains the employee 
name, staff number and the pay period number.  Additional fields can be added by selecting 

the relevant check boxes.  
 

Create an import template by selecting the 

Batch Management > Create Import 
File menu option. 

 

 
 

 
Selecting the fields to appear in the Import file 

 

Any additions or deductions already set up for the company can be added into the import file 
by ticking the relevant check boxes.  Before using an addition/deduction, a short code should 

be created against the item. The short code is used for the column headings in the import 
file. If an item with no short code is selected, a warning message will be displayed indicating 

that a “short code” is needed to use the item. Please see the instructions below on how to set 

up a short code.  
 

 
 
 

Adding a short code 
 

1. Select the Company > Additions & Deductions menu option. 

2. Select the addition/deduction that the short code is to be added to. 
3. Enter the short code (up to 20 characters), then click Save. 

 
Adding a Short code after receiving the warning message 

 
Click Yes to the message, which will take you to the additions/deductions setup screen. 

Follow steps 2 and 3 above. 
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Pay Frequency and Pay Week/Month 
 

 

Select the correct frequency using the radio buttons.  The 
software will then display the Pay Week/Month.  If an 

incorrect Pay Week/Month is displayed, then this can be 

changed by entering the correct Pay Week/Month in the 
Pay WM field.   

 
 

Selecting where to save the Import file 
 

By default the import file will be saved in the payroll installation folder.  To save the file in a 

different location click the  button and select the folder where the file should be saved.  
The name for the file is automatically created from the company name and the pay period 

the import file is for. 
 

 
 

When all the criteria for the import file have been set, click the Create File button.   
 

Editing the import file using a spreadsheet package 
 

On opening the import file with a spreadsheet package, a similar table will be displayed: 

 

EMP NAME EMP NO PAYWM bonus overtime BankHol ; 

Smith Paul 1 1    ; 

Webber Dave 4 1    ; 

White Emma 2 1    ; 

Williams Lee 3 1    ; 

 

Important Points 

 
The import file has a header row and a final column containing a semicolon, both of these 

features must not be altered in any way. 
 

Please note that if the file is opened using a spreadsheet package then the package may 
apply formatting on certain columns. E.g. Sort code fields may be seen as dates. 
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Importing Pay Files 

 

Select Import from the Batch Management 

menu. 

 
 

Click the  button to browse for the import file and when the file has been located click 
Import. 

 

 
  
“Import in Progress” warning message 

 
A message will be displayed if an import has not completed successfully or is currently in 

progress.  Check with the user displayed in the message that that the import has completed, 

then click the Clear Locks button. 
 

Click Import to start the import process again.  
 

File Validation 

 
During the import process the file is validated.  If any problems are found the import is 

aborted and an anomaly report is displayed detailing any errors.  
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Batch Maintenance 

The Batch Maintenance screen displays information on batches that have been imported 

and/or processed.     

 
Select Batch Maintenance from the Batch 

Management menu. 

 
 

Report 

 
Select the batch from the list and click Report to view a detailed summary of all the 

information in the batch. 
 

Manually Editing a Batch 

 
Highlight the batch to be edited and click Edit. This will open the Batch Input screen, which 

shows all the information within the selected batch. 
 

 
 

Select the entry to edit.  The value for that entry may be changed, or modify the type of the 
entry using the Short Description drop down box. 

 
The selected item can be removed completely by clicking the Delete button. 

 

For more information on using the Batch Input screen please see the Batch Input section on 
the next page. 
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Batch Input 

Select Add New Batch from the Batch 

Management menu. 

 
 

 

Entering a New Batch Manually 
 

• Enter the Pay period number that the batch is for. 

• Enter the Staff Number of the employee; the employee’s details will be populated 

automatically with the appropriate details. 
• Select the type of entry from the Short Description drop down box. 

• Enter the value for the entry in either the Hours or Amount fields. 

• Click Save to complete the batch, or Save and Add New to add another entry. 

 

Auto Fill Options 
 

Data entry speed can be increased by selecting one or more of the Auto Fill options.  E.g. If 

the same Addition had to be entered for each of the employees, then deselect Auto Fill 
Staff Number and select Auto Fill Addition Deduction. Each a new entry is added this 

would leave the staff number field blank, but would automatically populate the Short 
Description field with the last Addition / Deduction type used. 

 

 

 
Bulk Process   

Select Bulk Process from the Batch 
Management menu. 

 
 
Bulk processing will run any unprocessed batch imported for the selected company.  It is 

advisable to check the imported batches using Batch Maintenance before commencing any 
Bulk Processing. 

 

 

To process the batch, click 

Continue.  If any problems occur, 

an anomaly report will be produced.  
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Bulk Processing Options 

 
Pay All Employees who are not in batch: With this option selected any employee not in the 

batch file will be paid their normal basic rate/hours, or salary.  
 

Close Batch Employees after they are paid: All employees in the batch will be closed. 

 
 

 
Extra Input Types 

Select Extra Input Types from the Batch 

Management menu. 

 
 

 

 
These input types have been entered 

into the software, ready for use.  
Employee Number and Number of 

Weeks will appear regardless of type 
selected. 
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Employee Update 

Select Employee Update from the Batch 
Management menu. 

 
 

Using the Employee Update option allows employee maintenance records to be amended. 
Fields left blank will make nil change. 

 

 
 

Click the  button to browse for the import file and when the file has been located click 
Import. 
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FAQ’s 

 

 When paying a director no National Insurance has been deducted. 

 
Employees who have their National Insurance deducted as a director will not pay any NI until 

their Gross Pay to Date reaches the LEL (Lower Earnings Limit).  From then on National 
Insurance Contributions are calculated on all NICable earnings until the Gross Pay to Date 

reaches the UEL (Upper Earnings Limit).  The employee pays no National Insurance from this 

point on for the financial year. 
 

The limits can be found from the Help > Rates / NIC Bands Tab. 
 

 

 The system hasn’t paid the right number of days for a Tax Credit. 

 
This is due to the company calendar not being set correctly: 

Go to Company > Company Maintenance / Calendar Tab. 
Check to see if the Pay Period End Date is correct: 

If you pay a week-in-hand the Pay Period End Date should be a week prior to the Payslip 
Date. 

If you up to and including the day shown in the Payslip Date field the Pay Period End Date 

should be set the same. 
 

Setting the Dates 
Ensure the Tax Period Week/Month is set at 1. 

Change the Pay Period End Date as it should be, as at Period 1. 

Click Generate Dates. 
Click Save. 

 
 

 How do I print a P45? 

 
Highlight the employee by clicking the left mouse button over their name in the Employee 

Explorer list. 

Press the right mouse button and select Employee Maintenance from the context menu. 
On the Personal tab change the Payroll Status to Leaver. 

Enter the Leaving Date. 
Click Save then Close. 

Right click the employee in the Employee Explorer List and choose Employee Print > P45 

Certificate. 
 

 

  I’ve forgotten my password. 

 

We will be able to provide you with a temporary password by sending us written permission, 
Fax 0117 935 3545.   

The Fax must:  

Be on headed paper. 
Contain the authorizing persons printed name and signature.  

We will then call you back with the password. 
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 1) I’ve restored the software from a backup CD and now get this error.                                                        
 

  
 

By default the files held on a CD are read only and therefore have to be reset. 

Double click the My Computer icon on the windows desktop. 
Go to C:/Program Files/ and open the DIAMOND DISCOVERY directory for the year you are 

restoring (this is assuming the software has been installed in the default directory). 

Select all the files within the DIAMOND DISCOVERY directory. 
Press the right mouse button to display the context menu. 

Choose Properties. 
Remove the tick from the Read Only attribute. 

Click Save. 

Open the program as normal. 
 
 

 2) I’ve restored the software from a backup CD and now get this error. 
   

 
 

The software cannot simply be copied straight from a backup CD, but must be re-installed 

from the most recent DIAMOND DISCOVERY CD. 
 
 

 How do I transfer the payroll data from one computer to another? 
 

You will require 1 or more blank floppy disks to save your payroll data on. 
Back up your data by selecting Admin > Archive and Restore Data.  

Select Archive. 
 

 

 

 
 

 
 

Select the Floppy 
(A:) drive from the 

Save In dropdown 

menu. 
 

   
 

 

 
 

 

Click Save and the Archive operation will start. 

If your data is too large to fit on a single disk the software will prompt you to insert another 
blank disk, please remember to number the diskettes.  



 128 

The other computer must have DIAMOND DISCOVERY Business Payroll installed.  If it hasn’t 

it can be done from the latest DIAMOND DISCOVERY CD. 
On the computer you are transferring the data to, go to Admin > Archive and Restore Data. 

Select Restore. 
Select the Floppy (A:) drive. 

Select the backup file to restore. 

Click Open. 
You will be warned that the database already exists, Click Yes to All to complete the restore 

operation. 
Click Close on the Archive Utility and the software will exit. 

On re-opening DIAMOND DISCOVERY Business Payroll your data will have been restored. 

 
 

 
 

 
 

 

 
 

 


